summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-04-28 22:44:24 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-04-28 22:45:41 +0200
commitef1bbbf45cd1eceb15d2b0e2ab0461e8f544e2ae (patch)
tree57378f53eaf66360a3e61679af34080b7e478246
parentgnome-base/gnome-control-center: add 45.4 (diff)
downloadgentoo-ef1bbbf45cd1eceb15d2b0e2ab0461e8f544e2ae.tar.gz
gentoo-ef1bbbf45cd1eceb15d2b0e2ab0461e8f544e2ae.tar.bz2
gentoo-ef1bbbf45cd1eceb15d2b0e2ab0461e8f544e2ae.zip
net-misc/pedro: add 1.14
Bug: https://bugs.gentoo.org/913494 Closes: https://bugs.gentoo.org/870724 Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
-rw-r--r--net-misc/pedro/Manifest1
-rw-r--r--net-misc/pedro/files/pedro-1.14-portage.patch45
-rw-r--r--net-misc/pedro/pedro-1.14.ebuild58
3 files changed, 104 insertions, 0 deletions
diff --git a/net-misc/pedro/Manifest b/net-misc/pedro/Manifest
index 8f822449e20c..c7d6532e9f82 100644
--- a/net-misc/pedro/Manifest
+++ b/net-misc/pedro/Manifest
@@ -1,2 +1,3 @@
DIST pedro-1.12.tgz 1181678 BLAKE2B ed882ab3dae0912519283229d10ff6f12ef4f623d72beaf22b8467e8072752fbd57836a0ebbad0f0ce3da1b4837049161bcb12673e3c38c94eb167e16c0c0a1e SHA512 936b2c6cac526d9d3c0e146b53dc65ed0508c6abd1b66c97656fa5b4011d7dd11912d1c0bf091a29b56e13c3e19ec3e0ad7760d44d4887b939699cdd2389c819
+DIST pedro-1.14.tgz 1213309 BLAKE2B 104f3816d79534411ba5d78517a744d9a0bf892cf99a1c654a94b9041f4ff038c00d029b182b8f825cfe80cb9861e9440b4e73de3be1f74945a34dbaefb995e7 SHA512 ffe32c296c8325ea31a4bf5d937504e9076654253f19dea17b234f53ba62a4b96e8611cab1dbf545f30734cfd8924e4140b08956180886ac21849546b9ad0cad
DIST pedro-manual-1.x.tar.gz 222863 BLAKE2B 085b118585808aced9217a8001080b589d9dad958ad14787f929a4808b10bb2be80ae7bc04c07b676e41aed9e2ec916215c5d15dda2317f71ecebbc7c1737d96 SHA512 87f8e07e3a687d12e366f1974398996f2346e417680ab534622f901c0c7e1efeb171f0c0dadad46b578122c9e98531570c303d2d3ce04b1cd8150816d6138f99
diff --git a/net-misc/pedro/files/pedro-1.14-portage.patch b/net-misc/pedro/files/pedro-1.14-portage.patch
new file mode 100644
index 000000000000..c43b9f7d6ef8
--- /dev/null
+++ b/net-misc/pedro/files/pedro-1.14-portage.patch
@@ -0,0 +1,45 @@
+Addapted Gentoo patch from version 1.12
+
+diff --git a/configure.ac b/configure.ac
+index 21f803d..d89b296 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,30 +4,21 @@ AM_INIT_AUTOMAKE
+ AC_PROG_CC
+ AC_PROG_LEX([noyywrap])
+ AC_PROG_INSTALL
++AM_PROG_AR
+ AC_PROG_RANLIB
+ #AC_PROG_LIBTOOL
+ PKG_CHECK_MODULES([GLIB],[glib-2.0 >= 2.12])
+ AC_CONFIG_HEADERS(config.h)
+ AC_CONFIG_MACRO_DIR([m4])
+-CPPFLAGS="-DNDEBUG -O2 -g `pkg-config --cflags glib-2.0`"
++CPPFLAGS="`${PKG_CONFIG} --cflags glib-2.0`"
+ case "${host}" in
+- *i686*)
++ *-mingw32*)
+ WIN32="yes"
+- LDFLAGS=""
+- #LIBS="-L../lib -lpedro `pkg-config --libs glib-2.0` -lm"
+- LIBS="-L../lib -lpedro `pkg-config --libs glib-2.0` -lm -lwsock32 -lws2_32 -lwinmm"
+- ;;
+- *x86*)
+- WIN32="no"
+- LDFLAGS=""
+- #LIBS="-L../lib -lpedro `pkg-config --libs glib-2.0` -lm"
+- LIBS="-L../lib -lpedro `pkg-config --libs glib-2.0` -lm -lwsock32 -lws2_32 -lwinmm"
++ LIBS="-L../lib -lpedro `${PKG_CONFIG} --libs glib-2.0` -lm -lwsock32 -lws2_32 -lwinmm"
+ ;;
+ *)
+ WIN32="no"
+- #LDFLAGS="-L../lib -lpedro `pkg-config --libs glib-2.0` -lm"
+- LDFLAGS=""
+- LIBS="-L../lib -lpedro `pkg-config --libs glib-2.0` -lm"
++ LIBS="-L../lib -lpedro `${PKG_CONFIG} --libs glib-2.0` -lm"
+ ;;
+ esac
+ AC_CONFIG_FILES([Makefile src/Makefile src/server/Makefile src/lib/Makefile src/examples/Makefile doc/Makefile])
+--
+2.43.2
+
diff --git a/net-misc/pedro/pedro-1.14.ebuild b/net-misc/pedro/pedro-1.14.ebuild
new file mode 100644
index 000000000000..19bf94c63701
--- /dev/null
+++ b/net-misc/pedro/pedro-1.14.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Pedro is a subscription/notification communications system"
+HOMEPAGE="https://staff.itee.uq.edu.au/pjr/HomePages/PedroHome.html"
+SRC_URI="https://staff.itee.uq.edu.au/pjr/HomePages/PedroFiles/${P}.tgz
+ doc? ( https://dev.gentoo.org/~keri/distfiles/pedro/${PN}-manual-1.x.tar.gz )"
+S="${WORKDIR}"/${P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-portage.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export PKG_CONFIG
+
+ default
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ dodoc "${WORKDIR}"/${PN}.pdf
+ fi
+
+ if use examples ; then
+ docinto examples
+ dodoc src/examples/*.{c,tcl}
+
+ docinto examples/java_api
+ dodoc src/java_api/*.java
+
+ docinto examples/python_api
+ dodoc src/python_api/*.py
+ fi
+}