summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-03-01 02:18:55 -0500
committerTim Harder <radhermit@gentoo.org>2017-03-01 02:23:04 -0500
commitef2c7dc42e167d6196a5597608d60bdae5a5584e (patch)
tree0df3aca0aa3468ba87286a7c8615ee2ea20fd337
parentwww-client/opera: Old. (diff)
downloadgentoo-ef2c7dc4.tar.gz
gentoo-ef2c7dc4.tar.bz2
gentoo-ef2c7dc4.zip
dev-python/llfuse: version bump to 1.2
-rw-r--r--dev-python/llfuse/Manifest1
-rw-r--r--dev-python/llfuse/llfuse-1.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index b773c9fdfe57..537f7a37a1a1 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -5,3 +5,4 @@ DIST llfuse-0.43.tar.bz2 323979 SHA256 550c23c99ab1da711e816bdd980d588de174e143b
DIST llfuse-1.0.tar.bz2 323706 SHA256 fa521ce77a8c0ac1c8c21e6d4b0705dacc0ddd627439c2b3827c674909c027d2 SHA512 17d5fc91083dc29b11120980b68d000605582a757bf61a09ce4b840105fe0dc2b6afa416d09bf2abf11fd3c8bcbd5dfa4d90a9c9cc955c80a38111fb594e8b06 WHIRLPOOL aa8d22d0e7c6f5121c981c3c4fe7999aada35fa3bd5189c1ea14715366880af40105e8c35b4da7a098df449b277761a8dc50c489e65a074de430227599f032ac
DIST llfuse-1.1.1.tar.bz2 327071 SHA256 1b84b1152ae461e66ecc526d0de71eaec086c587e97d1dda93d620b16a92db6c SHA512 6541a55a740bac03edae8ce2562122e21655236c58c89cbb29b211a497c8a706ad79c7da485700b0842ba92fc8958799f62d552ce733aa8b3bfa8a6a3aa8c9a6 WHIRLPOOL d84b5108c0d6c25200f17709996c445d0fd2a3abbd37e54ece7e7a29b40f384da274a41ea7125ff84bb3932864d4d6dbf76372df96fa5b9d0cd33bb97c7cda2c
DIST llfuse-1.1.tar.bz2 326175 SHA256 e250d59f3ed0d91a6bdcf81ab8af5ade994de3abb96bc5e64cd465a8265e9ffb SHA512 8e468c35cf74ab25a17b17364bbb5b5c8ab02ab5f4fe911970792dc57b5a7d87bea3889a81ff8dafd4438de3ea1ec96ec974025a33f177c84347c0830c6e1432 WHIRLPOOL d49738f666478f0e267045df0a68435cdf7a12e95ead306ab678d6a56843ddd419be49d4bd8c76990b21b08e051f0ae7e5bf641d94c69c4ccc2e989f73711024
+DIST llfuse-1.2.tar.bz2 327967 SHA256 24d3ff1dd793db0c03cbbfb298df94a369ecdce5831f8f175ec12d647ad01586 SHA512 0c31ac385a98211f8696857654ea187c5f18b655b65199696923bcc66d079a5e2a6f7260ac4f6da17b25ed57c9cb1314ce62fabb3b538a87e4286bbd0763390b WHIRLPOOL c3c2d2cc022f6aeafc3b167e6ce4c0e8e3a2c6b302e1f9fd0bdbcfd48bf92415b41d333cb4d02f186fee2308fec9a9fa633608353190bedb39321636cd5b9c5a
diff --git a/dev-python/llfuse/llfuse-1.2.ebuild b/dev-python/llfuse/llfuse-1.2.ebuild
new file mode 100644
index 000000000000..d83b67937d9c
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://python-llfuse.googlecode.com/ https://pypi.python.org/pypi/llfuse"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples test"
+
+RDEPEND=">=sys-fs/fuse-2.8.0
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7)
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}