summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-28 17:10:43 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-28 17:15:11 +0100
commitef2e86b1586bbcaef117b8df2b79695c5886ac84 (patch)
treecaf7fd722af8ee0b8d2e9e5211ceefa124872c93
parentdev-python/netcdf4-python: Bump to 1.5.5 (diff)
downloadgentoo-ef2e86b1.tar.gz
gentoo-ef2e86b1.tar.bz2
gentoo-ef2e86b1.zip
xfce-extra/xfce4-mount-plugin: Bump to 1.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-mount-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.5.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mount-plugin/Manifest b/xfce-extra/xfce4-mount-plugin/Manifest
index 374c63ec1a4e..a13de926a0f0 100644
--- a/xfce-extra/xfce4-mount-plugin/Manifest
+++ b/xfce-extra/xfce4-mount-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-mount-plugin-1.1.3.tar.bz2 431182 BLAKE2B ba197ae9028b726e3b1e2b7fd68ebaec3e8e247322d916a1579681af9b004418d4738bfff05e7b947d6bcc5a1bd3cd1e0419f2e7421ae8cf7a7aeb3011658132 SHA512 10894069fd98fa0b709a3e743f0d6f9a8e9487b0de8495c3d177731190480f18b11b0179325d2ed47f80eeeaea10144ddce7f9cd60397dfb6a0db602bd4f8124
DIST xfce4-mount-plugin-1.1.4.tar.bz2 452224 BLAKE2B aad04c6aec4e624aa437f9a22f730e64d0ef2d11a76d98a082075477825767234e92ff6e97ee7821e36e49f97ef4fe86528660b20bfc3dd21d3b7f490e669dca SHA512 aff784688ca9b83acf7bf512b25fb7ad96c7b8a68d21bf466ccfbbbaed5e2d6884ac8222eb4a0db26c1763a932111114c6c2b76de89407553bc484f33ed036a0
+DIST xfce4-mount-plugin-1.1.5.tar.bz2 432564 BLAKE2B 6dbdbf692847c7c236a60982adf6ac9619f8d45320c97debea44e0b865a9ac51c76b20dd80943f5fe23501d450039ab0fc4644b0ff5ed693ff169668a039441d SHA512 bf4e89c57a1f61120919a272c6f343a9fb4072a977848031784cbdf96e4bf248d878c6e28a812930daf9a0515efcae20b421e0b2db176f05b8f29d75d90a28ca
diff --git a/xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.5.ebuild b/xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.5.ebuild
new file mode 100644
index 000000000000..5dce52b27f20
--- /dev/null
+++ b/xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="An mount plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-mount-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}