summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 05:14:40 +0000
committerSam James <sam@gentoo.org>2021-02-27 05:15:51 +0000
commitef3b07820955e5152f355d9fd294028aa73e203d (patch)
tree6924c3a8b9aaf328cfc0029853f7e229556524d1
parentprofiles/package.mask: last-rite sci-mathematics/ggnfs (diff)
downloadgentoo-ef3b0782.tar.gz
gentoo-ef3b0782.tar.bz2
gentoo-ef3b0782.zip
sci-libs/sundials: fix gcc 10 build
Closes: https://bugs.gentoo.org/707240 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/sundials/sundials-5.2.0.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sci-libs/sundials/sundials-5.2.0.ebuild b/sci-libs/sundials/sundials-5.2.0.ebuild
index aa14eeb5320d..3d60a524cc2c 100644
--- a/sci-libs/sundials/sundials-5.2.0.ebuild
+++ b/sci-libs/sundials/sundials-5.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -8,7 +8,7 @@ FORTRAN_NEEDED=fortran
FORTRAN_STANDARD="77 90"
# if FFLAGS and FCFLAGS are set then should be equal
-inherit cmake fortran-2 toolchain-funcs
+inherit cmake fortran-2 toolchain-funcs flag-o-matic
DESCRIPTION="Suite of nonlinear solvers"
HOMEPAGE="https://computation.llnl.gov/projects/sundials"
@@ -38,6 +38,13 @@ pkg_setup() {
fi
}
+src_prepare() {
+ # bug #707240
+ append-cflags -fcommon
+
+ cmake_src_prepare
+}
+
src_configure() {
mycmakeargs+=(
-DBUILD_SHARED_LIBS=ON