summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-13 10:32:12 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-13 10:33:42 +0100
commitef54afc66ecacedab36f44dc80a4579d80823893 (patch)
treed162d7e7fb6555ca5ba36efdb7923269c65d1218
parentdev-python/pylama: Remove old (diff)
downloadgentoo-ef54afc66ecacedab36f44dc80a4579d80823893.tar.gz
gentoo-ef54afc66ecacedab36f44dc80a4579d80823893.tar.bz2
gentoo-ef54afc66ecacedab36f44dc80a4579d80823893.zip
dev-python/urllib3: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/urllib3/Manifest1
-rw-r--r--dev-python/urllib3/urllib3-1.26.7.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 8a6f8142e297..a1e8cdf4bc13 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,2 +1 @@
-DIST urllib3-1.26.7.tar.gz 291350 BLAKE2B 5a95ea4df2e5a66ac7f3059b5453e122ae0e40531a23cb743e5a9574778a370d0cee3cb63fe6b29483b27c4a6ec498266ec5a0434db882ce0a79fb8d8400e08d SHA512 6f5a5e6dd5ff99950fcc051495e0a698153b57e20b6c83d869b54c7fece9616909bcf2fe99efc40815f8722996ad93e430bf765ce5c629b912690c286014b86f
DIST urllib3-1.26.8.tar.gz 294280 BLAKE2B 401801b16c0c5152cabdfe3317cc53bc79a5aec103cc53a22189dcefcf0d022a05f6afac0bd99274a2fe48b6e86da8eb544b78e4c3a1534f000a9756ff15ccd9 SHA512 bcb56faa5dbe6019f70b63c076e118ec5f89e2d0c25f0e415d9db079532c98ced7e636cec5bf26210d4b0a08bb7b5b7a33a5c8648ccdaad129eea3a212a53bc5
diff --git a/dev-python/urllib3/urllib3-1.26.7.ebuild b/dev-python/urllib3/urllib3-1.26.7.ebuild
deleted file mode 100644
index 83948b0c34e9..000000000000
--- a/dev-python/urllib3/urllib3-1.26.7.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
-HOMEPAGE="https://github.com/urllib3/urllib3"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="brotli test"
-RESTRICT="!test? ( test )"
-
-# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
-# dependencies. Do not add them to RDEPEND. They should be unnecessary with
-# modern versions of python (>= 3.2).
-RDEPEND="
- >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
- <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
- brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep "
- ${RDEPEND}
- dev-python/brotlicffi[\${PYTHON_USEDEP}]
- dev-python/mock[\${PYTHON_USEDEP}]
- dev-python/pytest[\${PYTHON_USEDEP}]
- dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
- >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
- >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
- " python3_{8..10})
- )
-"
-
-python_test() {
- local -x CI=1
- # FIXME: get tornado ported
- # please keep in sync with BDEPEND!
- if ! has "${EPYTHON}" python3.{8..10}; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local EPYTEST_DESELECT=(
- # TODO?
- test/contrib/test_pyopenssl.py::TestHTTPS_TLSv1_3::test_verified
- test/with_dummyserver/test_socketlevel.py::TestSocketClosing::test_timeout_errors_cause_retries
- )
-
- epytest
-}