summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-02-23 21:38:27 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-02-23 21:43:16 +0000
commitef6e588bd4162c4019914fc23871b9ee1709a170 (patch)
tree6306673841a7ea81db55617fa9b874bc4c2066cb
parentnet-misc/minidlna: drop old version. (diff)
downloadgentoo-ef6e588bd4162c4019914fc23871b9ee1709a170.tar.gz
gentoo-ef6e588bd4162c4019914fc23871b9ee1709a170.tar.bz2
gentoo-ef6e588bd4162c4019914fc23871b9ee1709a170.zip
x11-libs/xpa: Version bump
Package-Manager: portage-2.2.27
-rw-r--r--x11-libs/xpa/Manifest1
-rw-r--r--x11-libs/xpa/xpa-2.1.17.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-libs/xpa/Manifest b/x11-libs/xpa/Manifest
index 4f983325ef0a..a4280b79eb6d 100644
--- a/x11-libs/xpa/Manifest
+++ b/x11-libs/xpa/Manifest
@@ -1 +1,2 @@
DIST xpa-2.1.15.tar.gz 861859 SHA256 ac0e041f9115757fbcbfeb377cb5833544815a70f2b46f6edfbf6d1239ae690a SHA512 62b453eb138197b452fca8d1ded1df97be54bcfbd13a0d5fecafc206c1589913c7d09593247077fb07c8b66a87ac0b22b95dfe74c49f2bd0abb942942fa87ce8 WHIRLPOOL 7dea8b931a1734c216ccfb79604ef5d291e1ea9230bbf0859895ac132ed2ceb7bc8ca13957d2022c34b641e740febf344b44e897faabf5aec9faf5761cf5213f
+DIST xpa-2.1.17.tar.gz 900465 SHA256 c95ae1d6c5353226a90f29007822e98da42a036af2f7326a21d2f66189c49751 SHA512 c9742b8427a9d8512a429f5a3b2bc6a55803b975c1524ead64906a4387a589f229e8715c46814b7b1bfb30a05f2f5fe59e944e1dabc333fcceca71c569a05a50 WHIRLPOOL 7426629091bc73d82ea87ce3db64b6f18f98f47bf98a45cc89971dbd0a88b44ee9eabe3e34e645e62a046fdb5b84258668f04616c38a34482f061e59b85445fb
diff --git a/x11-libs/xpa/xpa-2.1.17.ebuild b/x11-libs/xpa/xpa-2.1.17.ebuild
new file mode 100644
index 000000000000..6c93fa4b06a7
--- /dev/null
+++ b/x11-libs/xpa/xpa-2.1.17.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Messaging system providing communication between programs"
+HOMEPAGE="https://github.com/ericmandel/xpa"
+SRC_URI="https://github.com/ericmandel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ x11-libs/libXt:0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.8-makefile.patch
+ sed -i -e "s:\${LINK}:\${LINK} ${LDFLAGS}:" mklib || die
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --enable-threaded-xpans \
+ --with-x \
+ --with-tcl \
+ --with-threads
+}
+
+src_compile() {
+ emake shlib tclxpa
+}
+
+src_install () {
+ dodir /usr/$(get_libdir)
+ emake INSTALL_ROOT="${D}" install
+ insinto /usr/$(get_libdir)/tclxpa
+ doins pkgIndex.tcl
+ mv "${ED}"/usr/$(get_libdir)/libtclxpa* \
+ "${ED}"/usr/$(get_libdir)/tclxpa/ || die
+ dodoc README
+ use doc && dodoc doc/*.pdf && dohtml doc/*.html
+ # build system so crappy not worth patching to a non respondant upstream
+ # and builds static with PIC
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
+}