summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-05-30 22:57:19 +0200
committerDavid Seifert <soap@gentoo.org>2019-05-30 22:57:19 +0200
commitef74c44c238483b682040c420b4a566ad483d11e (patch)
tree5a2df88ffb8b2e025c619eac943da07b55bcf31a
parentdev-libs/newt: drop old (diff)
downloadgentoo-ef74c44c.tar.gz
gentoo-ef74c44c.tar.bz2
gentoo-ef74c44c.zip
dev-util/cram: Add pypy3 and py3.7 support
* EAPI=7 * Add test suite * Remove py2, as it causes failures in the test suite when dev-python/configparser is installed Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-util/cram/cram-0.7.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-util/cram/cram-0.7.ebuild b/dev-util/cram/cram-0.7.ebuild
index 05dedeb0a0af..80888de3e6c4 100644
--- a/dev-util/cram/cram-0.7.ebuild
+++ b/dev-util/cram/cram-0.7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
inherit distutils-r1
@@ -14,7 +14,8 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 x86 ~amd64-fbsd ~x86-fbsd"
-IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
+python_test() {
+ distutils_install_for_testing
+ "${EPYTHON}" "${TEST_DIR}"/scripts/cram tests || die "Tests fail with ${EPYTHON}"
+}