summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:09:50 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:09 +0100
commitef83c7bdc7ef98f2d3d723a97cf6e0922657842c (patch)
tree8ede336a3241b0c61a4dcfda99fc08480e753bb9
parentdev-haskell/strict: add 0.5 (diff)
downloadgentoo-ef83c7bdc7ef98f2d3d723a97cf6e0922657842c.tar.gz
gentoo-ef83c7bdc7ef98f2d3d723a97cf6e0922657842c.tar.bz2
gentoo-ef83c7bdc7ef98f2d3d723a97cf6e0922657842c.zip
dev-haskell/string-qq: Loosen constraint on text
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/string-qq/metadata.xml4
-rw-r--r--dev-haskell/string-qq/string-qq-0.0.4-r1.ebuild (renamed from dev-haskell/string-qq/string-qq-0.0.4.ebuild)21
2 files changed, 17 insertions, 8 deletions
diff --git a/dev-haskell/string-qq/metadata.xml b/dev-haskell/string-qq/metadata.xml
index 937381521944..9a37700a12e3 100644
--- a/dev-haskell/string-qq/metadata.xml
+++ b/dev-haskell/string-qq/metadata.xml
@@ -5,4 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <upstream>
+ <remote-id type="hackage">string-qq</remote-id>
+ <remote-id type="github">audreyt/string-qq</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/string-qq/string-qq-0.0.4.ebuild b/dev-haskell/string-qq/string-qq-0.0.4-r1.ebuild
index 7bea336c92ed..e91d09d195dc 100644
--- a/dev-haskell/string-qq/string-qq-0.0.4.ebuild
+++ b/dev-haskell/string-qq/string-qq-0.0.4-r1.ebuild
@@ -1,26 +1,31 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-# ebuild generated by hackport 0.6.9999
+# ebuild generated by hackport 0.8.2.1.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="QuasiQuoter for non-interpolated strings, texts and bytestrings"
HOMEPAGE="https://hackage.haskell.org/package/string-qq"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="public-domain"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-IUSE=""
-RDEPEND=">=dev-lang/ghc-7.4.1:=
+CABAL_CHDEPS=(
+ 'text >=1.2 && <1.3' 'text >=1.2'
+)
+
+RDEPEND="
+ >=dev-lang/ghc-8.8.1:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( >=dev-haskell/hunit-1.6 <dev-haskell/hunit-1.7
- >=dev-haskell/text-1.2 <dev-haskell/text-1.3 )
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ >=dev-haskell/hunit-1.6 <dev-haskell/hunit-1.7
+ >=dev-haskell/text-1.2
+ )
"