summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-09-02 16:04:07 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-09-02 16:04:21 +0200
commitef8737ee7fcd95460c8d5d669aa94248cc2991fd (patch)
treeb5abbd12867b9b667fbc3485fd1d5797ddaf0db4
parentdev-util/strace: Synced live ebuild (diff)
downloadgentoo-ef8737ee.tar.gz
gentoo-ef8737ee.tar.bz2
gentoo-ef8737ee.zip
dev-util/strace: Removed old
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-util/strace/Manifest1
-rw-r--r--dev-util/strace/strace-5.11.ebuild105
2 files changed, 0 insertions, 106 deletions
diff --git a/dev-util/strace/Manifest b/dev-util/strace/Manifest
index b893fb008f51..5cf1d94cb93a 100644
--- a/dev-util/strace/Manifest
+++ b/dev-util/strace/Manifest
@@ -1,4 +1,3 @@
-DIST strace-5.11.tar.xz 1926632 BLAKE2B df47612c0928466f8b5788c4a7dc74208fe76c6967d3219b0eb753131fba315e715626c2cd1ed56d3e8ba0eb9a338589a8cbd6205fe876123ac26fdf0fab8d31 SHA512 688bec8d620c7ca701561ed7479e42687cc30737f944b82201731d827775cd2864787ecca7c93ba149b06d5d654d9f6bd109a977f8138bab34339cd5930828f0
DIST strace-5.12.tar.xz 2009060 BLAKE2B 9a7a07e5d2d38c8b456f54d0e1d7c776066b20327fa08d562e426a7096f708dffa00f0c2121683fa71f7029db958d450c5a6abf5ae5970dc02732f5aa7cef591 SHA512 289cf82da4c69270458953b45d09c8eb05a6624898d3ac493c3ec293cd5ad07205084ad0af021dab2be9c0dc53f0301816113a746d96c78780b79231a185e7c9
DIST strace-5.13.tar.xz 2040116 BLAKE2B a604342d68f504b42ff1cb4918aa9ced6575f589caeb62f53e0b125f24cfaf0423f1911f352f21ecea0d702197d65edc85d3e97ffca3561f619f9c4c80386cdc SHA512 ba8b0eae396fa2b762bf17cbcdcd84b0660b2a5d5e7e9caf098ef3414a87fd28d4140dd10136483f35904560e5044e40be2bf6117462868a360306d62887c8ed
DIST strace-5.14.tar.xz 2067020 BLAKE2B 479ecf5e66e26e722d108c905130f482c411857db234ac013bf3568905c0f7b896f001ba6da2cabccd0a987c7802aebec9c6298decb691de125e8154c28e1c6f SHA512 3e147521773d900167809db9feeb148e8ba116f90dd634311941ea335eb7bd8b73ab9e641bd2dcfe899ab41c19a841e203dc771ec3000ae01452d22ecdc43c5a
diff --git a/dev-util/strace/strace-5.11.ebuild b/dev-util/strace/strace-5.11.ebuild
deleted file mode 100644
index d71516e9a04d..000000000000
--- a/dev-util/strace/strace-5.11.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/strace/strace.git"
- inherit git-r3 autotools
-else
- SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
-HOMEPAGE="https://strace.io/"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="aio perl static unwind elfutils"
-
-REQUIRED_USE="?? ( unwind elfutils )"
-
-BDEPEND="
- virtual/pkgconfig
-"
-LIB_DEPEND="
- unwind? ( sys-libs/libunwind[static-libs(+)] )
- elfutils? ( dev-libs/elfutils[static-libs(+)] )
-"
-# strace only uses the header from libaio to decode structs
-DEPEND="
- static? ( ${LIB_DEPEND} )
- aio? ( >=dev-libs/libaio-0.3.106 )
- sys-kernel/linux-headers
-"
-RDEPEND="
- !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
- perl? ( dev-lang/perl )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.11-static.patch"
-)
-
-src_prepare() {
- default
-
- eautoreconf
-
- if [[ ! -e configure ]] ; then
- # git generation
- sed /autoreconf/d -i bootstrap || die
- ./bootstrap || die
- eautoreconf
- [[ ! -e CREDITS ]] && cp CREDITS{.in,}
- fi
-
- filter-lfs-flags # configure handles this sanely
-
- export ac_cv_header_libaio_h=$(usex aio)
- use elibc_musl && export ac_cv_header_stdc=no
-
- # Stub out the -k test since it's known to be flaky. #545812
- sed -i '1iexit 77' tests*/strace-k.test || die
-}
-
-src_configure() {
- # Set up the default build settings, and then use the names strace expects.
- tc-export_build_env BUILD_{CC,CPP}
- local v bv
- for v in CC CPP {C,CPP,LD}FLAGS ; do
- bv="BUILD_${v}"
- export "${v}_FOR_BUILD=${!bv}"
- done
-
- # Don't require mpers support on non-multilib systems. #649560
- local myeconfargs=(
- --disable-gcc-Werror
- --enable-mpers=check
- $(use_enable static)
- $(use_with unwind libunwind)
- $(use_with elfutils libdw)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- if has usersandbox ${FEATURES} ; then
- ewarn "Test suite is known to fail with FEATURES=usersandbox -- skipping ..." #643044
- return 0
- fi
-
- default
-}
-
-src_install() {
- default
- if use perl ; then
- exeinto /usr/bin
- doexe src/strace-graph
- fi
- dodoc CREDITS
-}