summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-12-23 23:00:55 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-12-23 23:00:55 +0100
commitefc06b147da28f8b8cc2237cac197fda02ff8c7c (patch)
tree2eb2f1943e5c8415edcfb86f1d65a01b40dd7033
parentdev-ruby/classifier-reborn: Add ruby23, drop ruby20 (diff)
downloadgentoo-efc06b14.tar.gz
gentoo-efc06b14.tar.bz2
gentoo-efc06b14.zip
dev-util/cookiecutter: Version bump to 1.5.0
Package-Manager: portage-2.3.3
-rw-r--r--dev-util/cookiecutter/Manifest1
-rw-r--r--dev-util/cookiecutter/cookiecutter-1.5.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/cookiecutter/Manifest b/dev-util/cookiecutter/Manifest
index ef7f38e2a473..b7bac0d41689 100644
--- a/dev-util/cookiecutter/Manifest
+++ b/dev-util/cookiecutter/Manifest
@@ -1 +1,2 @@
DIST cookiecutter-1.4.0.tar.gz 226136 SHA256 7697b1d64cd9b8eb5abd9e7594e318a80f1382f45d879c425944175697b29db2 SHA512 21cc9293b81c21f9256a73728310bd7898b2132bc007ef650ba94394e872aa97dfba83b93018923e773b908f8822f5f9d992e5cc078936e2f9ba032f3cc83f9d WHIRLPOOL d1b01766fa42eaa46b6fefe2b82ebe7712c83327e08704ddc938c8dc8f5fb0167e2d1cfe47373274f2ef387c4a253d9f88b46ac57804ed7557b8585da94b7590
+DIST cookiecutter-1.5.0.tar.gz 246654 SHA256 553d00dcbdb6eed252ff15b5622ed98b2a22ffa96fc1b49717b4fbea32378526 SHA512 4b80577966e735da688e8a8c924a4692cf09b1e6c63dbadcac428dd60511bf917a9fe7cd4b00ed06b0f0636501e335dd8acc61c5df435b860ce130a5f52b6b62 WHIRLPOOL c7637e7b0dc0982c1b9189d9a2ab9717c2f6f25f574b608b5a1c40a36ff8b8a497a6488a0a58ccfb014b3a70fd4923271b47dbce8f29acc8a2a5e5c3f5e39e81
diff --git a/dev-util/cookiecutter/cookiecutter-1.5.0.ebuild b/dev-util/cookiecutter/cookiecutter-1.5.0.ebuild
new file mode 100644
index 000000000000..e56a33a6a7aa
--- /dev/null
+++ b/dev-util/cookiecutter/cookiecutter-1.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Command-line utility to create projects from cookiecutters (project templates)"
+HOMEPAGE="https://github.com/audreyr/cookiecutter"
+
+SRC_URI="https://github.com/audreyr/cookiecutter/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RESTRICT="test" # tests currently fail here
+
+RDEPEND=">=dev-python/binaryornot-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/future-0.15.2[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/whichcraft-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/poyo-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja2-time-0.1.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.1[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst HISTORY.rst CONTRIBUTING.rst )
+
+python_test() {
+ py.test || die
+}