summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-06-05 22:11:20 +1200
committerKent Fredric <kentnl@gentoo.org>2017-06-05 22:13:20 +1200
commitefc9615fc05746c0a58c4a59c611a0f3704513eb (patch)
treea97993f9f4a10622767e1e6494a99139f74a1078
parentapp-text/jo: Version bump. (diff)
downloadgentoo-efc9615f.tar.gz
gentoo-efc9615f.tar.bz2
gentoo-efc9615f.zip
dev-perl/WebService-MusicBrainz: Bump to version 1.0.2
- Network tests now controlled by DIST_TEST_OVERRIDE=network support Upstream: - Rewrite using Mojolicious - Implement version 2.0 of MusicBrainz API Keywords: - Dropped ppc/ppc64 due to new Mojolicious dep Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-perl/WebService-MusicBrainz/Manifest1
-rw-r--r--dev-perl/WebService-MusicBrainz/WebService-MusicBrainz-1.0.2.ebuild21
-rw-r--r--dev-perl/WebService-MusicBrainz/files/1.0.2-no-network-testing.patch93
-rw-r--r--dev-perl/WebService-MusicBrainz/metadata.xml61
4 files changed, 128 insertions, 48 deletions
diff --git a/dev-perl/WebService-MusicBrainz/Manifest b/dev-perl/WebService-MusicBrainz/Manifest
index 9c7f349178fd..9816998cb0fb 100644
--- a/dev-perl/WebService-MusicBrainz/Manifest
+++ b/dev-perl/WebService-MusicBrainz/Manifest
@@ -1,2 +1,3 @@
DIST WebService-MusicBrainz-0.93.tar.gz 23378 SHA256 c1bc124f1d97e970d7752a09499710d1a47986581a40ace53852928d4d17e6bd SHA512 52b61dc10dd406aafec3eaac01aa7cebd240176bc3ef10fd00be543b146ac23ef8f90ec6c1bab37ea5440292cf3fd9f599bc0df92a09d749f3df4f7c546ac2c8 WHIRLPOOL c75b946c9e86cff848f6edbb534d42aa334c25778a6220b6520f337cdea38e02bfd423c6011d360f2369adc0e5b6d99a3ecc978d0e7534114ad9425cbcef87cd
DIST WebService-MusicBrainz-0.94.tar.gz 29800 SHA256 9b227b24dbf5f0159dd8fda1ed91c3cbf094b586da4e1207bdb9ad16ba71e005 SHA512 4c73aa4e1407bb17567e0ad618771ffae47aa87925ef516640af6bb16e4dde2657a5c16bfa2dea2379b67812a2eee253d0642e4b2d73d43929d031f5917e51f0 WHIRLPOOL 398a0f5cfc2f90e5c79edabe4ea8fddc0a6b518dfcecef49505dc3dc0e32874506235bfc6a9a20be457977ea0faa54cbd2d363efc604596ea4c42debc94e9186
+DIST WebService-MusicBrainz-1.0.2.tar.gz 9547 SHA256 37e0a132f501b630d221a19c7d6817cd4347ed8da8d85e7ff62d75a9a9450c0a SHA512 fc5f2744ad52d01e671c6dfcf011c334762f3655d200e47ab8aa48752755a74530f854870961243e2ccea727b287df549fbebe579c6ca5bb70d94edf5c508ce6 WHIRLPOOL f896938114756be49c3dde5eb3fe23c2aa5bada0cf91e1b0e73db9e2b1c06815b68f03cdb76b3ada81f4181095ff7e8c2a0c71d3aa0b4ed9509354ba075f93b9
diff --git a/dev-perl/WebService-MusicBrainz/WebService-MusicBrainz-1.0.2.ebuild b/dev-perl/WebService-MusicBrainz/WebService-MusicBrainz-1.0.2.ebuild
new file mode 100644
index 000000000000..5e779aa0945d
--- /dev/null
+++ b/dev-perl/WebService-MusicBrainz/WebService-MusicBrainz-1.0.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=BFAIST
+DIST_VERSION=1.0.2
+inherit perl-module
+
+DESCRIPTION="Web service API to MusicBrainz database"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+PATCHES=( "${FILESDIR}/1.0.2-no-network-testing.patch" )
+RDEPEND="
+ >=dev-perl/Mojolicious-7.130.0
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.420.0
+"
diff --git a/dev-perl/WebService-MusicBrainz/files/1.0.2-no-network-testing.patch b/dev-perl/WebService-MusicBrainz/files/1.0.2-no-network-testing.patch
new file mode 100644
index 000000000000..aed22f3ab275
--- /dev/null
+++ b/dev-perl/WebService-MusicBrainz/files/1.0.2-no-network-testing.patch
@@ -0,0 +1,93 @@
+From ccae912f85bde814a8286786dea50ecd8afde014 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Mon, 5 Jun 2017 22:03:46 +1200
+Subject: [PATCH] Disable network IO tests when NO_NETWORK_TESTING in ENV
+
+Network tests are sandboxed in Portage in some conditions,
+so disabling tests unless explicitly asked for is required.
+---
+ t/Area.t | 7 +++++++
+ t/Artist.t | 7 +++++++
+ t/Label.t | 7 +++++++
+ t/Recording.t | 7 +++++++
+ t/Release.t | 7 +++++++
+ 5 files changed, 35 insertions(+)
+
+diff --git a/t/Area.t b/t/Area.t
+index 143d72a..dd54a70 100644
+--- a/t/Area.t
++++ b/t/Area.t
+@@ -1,3 +1,10 @@
++BEGIN {
++ if ( $ENV{NO_NETWORK_TESTING} ) {
++ print '1..0 # SKIP Network connections required for this test';
++ exit;
++ }
++}
++
+ use strict;
+ use Test::More;
+
+diff --git a/t/Artist.t b/t/Artist.t
+index 5b6c47a..cfe2a4c 100644
+--- a/t/Artist.t
++++ b/t/Artist.t
+@@ -1,3 +1,10 @@
++BEGIN {
++ if ( $ENV{NO_NETWORK_TESTING} ) {
++ print '1..0 # SKIP Network connections required for this test';
++ exit;
++ }
++}
++
+ use strict;
+ use Test::More;
+
+diff --git a/t/Label.t b/t/Label.t
+index 9da331e..09887ca 100644
+--- a/t/Label.t
++++ b/t/Label.t
+@@ -1,3 +1,10 @@
++BEGIN {
++ if ( $ENV{NO_NETWORK_TESTING} ) {
++ print '1..0 # SKIP Network connections required for this test';
++ exit;
++ }
++}
++
+ use strict;
+ use Test::More;
+
+diff --git a/t/Recording.t b/t/Recording.t
+index 4077221..fa28295 100644
+--- a/t/Recording.t
++++ b/t/Recording.t
+@@ -1,3 +1,10 @@
++BEGIN {
++ if ( $ENV{NO_NETWORK_TESTING} ) {
++ print '1..0 # SKIP Network connections required for this test';
++ exit;
++ }
++}
++
+ use strict;
+ use Test::More;
+
+diff --git a/t/Release.t b/t/Release.t
+index 146b9fe..1ed12ba 100644
+--- a/t/Release.t
++++ b/t/Release.t
+@@ -1,3 +1,10 @@
++BEGIN {
++ if ( $ENV{NO_NETWORK_TESTING} ) {
++ print '1..0 # SKIP Network connections required for this test';
++ exit;
++ }
++}
++
+ use strict;
+ use Test::More;
+
+--
+2.12.2
+
diff --git a/dev-perl/WebService-MusicBrainz/metadata.xml b/dev-perl/WebService-MusicBrainz/metadata.xml
index 09c18853d4f3..226c1690319d 100644
--- a/dev-perl/WebService-MusicBrainz/metadata.xml
+++ b/dev-perl/WebService-MusicBrainz/metadata.xml
@@ -1,52 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
-<email>perl@gentoo.org</email>
-<name>Gentoo Perl Project</name>
-</maintainer>
-<maintainer type="project">
-<email>sound@gentoo.org</email>
-<name>Gentoo Sound project</name>
-</maintainer>
-<upstream>
-<remote-id type="cpan">WebService-MusicBrainz</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Artist</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Label</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Query</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Release</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::ReleaseGroup</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::Alias</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::AliasList</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::Artist</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::ArtistList</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::Disc</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::DiscList</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::ISRC</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::ISRCList</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::Label</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::LabelList</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::Metadata</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::Puid</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::PuidList</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::Rating</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::Relation</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::RelationList</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::Release</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::ReleaseEvent</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::ReleaseEventList</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::ReleaseGroup</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::ReleaseGroupList</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::ReleaseList</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::Tag</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::TagList</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::Track</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::TrackList</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::UserRating</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::UserTag</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Response::UserTagList</remote-id>
-<remote-id type="cpan-module">WebService::MusicBrainz::Track</remote-id>
-</upstream>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">WebService-MusicBrainz</remote-id>
+ <remote-id type="cpan-module">WebService::MusicBrainz</remote-id>
+ <remote-id type="cpan-module">WebService::MusicBrainz::Request</remote-id>
+ </upstream>
</pkgmetadata>