summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-01-19 01:35:16 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-01-19 01:39:30 -0500
commiteff3cad79f0aff0d8b6ce59c46325181cdc25ae4 (patch)
tree60b8bafe4d2f7c4bff911aa1a822eb0fb9c42098
parentx11-terms/kitty-terminfo: add 0.32.0 (diff)
downloadgentoo-eff3cad79f0aff0d8b6ce59c46325181cdc25ae4.tar.gz
gentoo-eff3cad79f0aff0d8b6ce59c46325181cdc25ae4.tar.bz2
gentoo-eff3cad79f0aff0d8b6ce59c46325181cdc25ae4.zip
x11-terms/kitty: add 0.32.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-terms/kitty/Manifest3
-rw-r--r--x11-terms/kitty/kitty-0.32.0.ebuild176
2 files changed, 179 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index b0b5772c379a..764aace987f3 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -1,3 +1,6 @@
DIST kitty-0.31.0-vendor.tar.xz 1397172 BLAKE2B 0c3bf3cece86cec651ec6dd4a97923464636885e5c9ef44b0e094d34ea66ca1b8176cc7d2647eda0030f857faf5e87e506ec9af6465487ef9a61efd634492d86 SHA512 41699cbd112f429d78dbf5b7716b3b017d5decd3649a13913e273a5b1ab6177ab7d93c5d2e3cb9b927846f41ada91f8cf95e7148e52d6a3bf914e7b116b7b072
DIST kitty-0.31.0.tar.xz 7929620 BLAKE2B 74ccd0e14803ee3991d895c8ec0099567b6a087110eda03d5b35a45d1e684916d63846f1bd1184b2f5fe7a88431983602899cfd6392c28de78d020b8c98c89b2 SHA512 3868431003f9f1a3907415124c1d8282b077985a9d104615d48f9d309f6fbf1a11119546674508649aa35f2b6e66aa5638024e8127f92ae7b043da367c7b3363
DIST kitty-0.31.0.tar.xz.sig 566 BLAKE2B 5013b35dd7119b5bed3e4fefee70009f6fe6ba8c3215a35e82fdd3929063ef32c58c77f12c246374693801936ac362c3d432da95c91b632fdb848d98b3cf0bf9 SHA512 cc8583bbdd9e23a005cecb87f5d7d72ada5db1a1a8cdf59a67a103fc0c11df403df2673434d373216415903b6967a1638bf3f51ff7474368d618685a542d4280
+DIST kitty-0.32.0-vendor.tar.xz 1404384 BLAKE2B 5b7d2af146429354e25d9b4f5c43a769535ad9a3b31b5a2944b8d8e7f045630734bd8e92c3f40c5dd7111d5014b9b356972896c0ba005392fbb740bc4bb30b20 SHA512 00b94033ea8b6ae3bbe509fdc2443aa7405a59ff9c04d86b96bd4dfe002367517b5b1fa99f27b8e2424917bb6b2eaa5959e8f470cd524de6388760870779af89
+DIST kitty-0.32.0.tar.xz 8122660 BLAKE2B 8f2fccb8f233612331b860e0b25aa5a028c2e4d39b5795132351c4a2dff51478b8e42fd3a15bec5f616b4cdb47ad0cc7f636d1961a7f9fad8ede91475e82c29e SHA512 d64f36c20d484724b0215a2ffc9044b83ddaa476926377e6c79226d7d6bd5deffda9964291a99c0df174640fb2fa7df0464435d2cef19304eab7b1d135cc1847
+DIST kitty-0.32.0.tar.xz.sig 566 BLAKE2B e925423321ec88fd0e7cc4f356c92b9ca9d992dce4c480c383368eff81f97bae4ac5a1d2cc2a7a2f3603f32448aa5d817c2319681dd1e2c24150834e137f55fa SHA512 fe7ce2dceb22ee477d6a9e3b308f4ef54287d1656f949511e80a6c9ee1d921bab5599675e354e6dd8b35719b0ff5373a9cca73b255da3c03aaed239e7355c897
diff --git a/x11-terms/kitty/kitty-0.32.0.ebuild b/x11-terms/kitty/kitty-0.32.0.ebuild
new file mode 100644
index 000000000000..ad738d565f30
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.32.0.ebuild
@@ -0,0 +1,176 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit edo go-env optfeature multiprocessing
+inherit python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+else
+ inherit verify-sig
+ SRC_URI="
+ https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz
+ https://dev.gentoo.org/~ionen/distfiles/${P}-vendor.tar.xz
+ verify-sig? ( https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz.sig )
+ "
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Fast, feature-rich, GPU-based terminal"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+
+LICENSE="GPL-3 ZLIB"
+LICENSE+=" Apache-2.0 BSD BSD-2 MIT MPL-2.0" # go
+SLOT="0"
+IUSE="+X test wayland"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( X wayland )
+ test? ( X wayland )
+"
+RESTRICT="!test? ( test )"
+
+# dlopen: fontconfig,libglvnd
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/openssl:=
+ dev-libs/xxhash
+ media-libs/fontconfig
+ media-libs/harfbuzz:=[truetype]
+ media-libs/lcms:2
+ media-libs/libglvnd[X?]
+ media-libs/libpng:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libxkbcommon[X?]
+ x11-misc/xkeyboard-config
+ ~x11-terms/kitty-shell-integration-${PV}
+ ~x11-terms/kitty-terminfo-${PV}
+ X? (
+ x11-libs/libX11
+ x11-libs/libXcursor
+ )
+ wayland? ( dev-libs/wayland )
+ !sci-mathematics/kissat
+"
+DEPEND="
+ ${RDEPEND}
+ X? (
+ x11-base/xorg-proto
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ )
+ wayland? ( dev-libs/wayland-protocols )
+"
+# bug #919751 wrt go subslot
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-lang/go-1.21:=
+ sys-libs/ncurses
+ virtual/pkgconfig
+ test? ( $(python_gen_cond_dep 'dev-python/pillow[${PYTHON_USEDEP}]') )
+ wayland? ( dev-util/wayland-scanner )
+"
+[[ ${PV} == 9999 ]] || BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )"
+
+QA_FLAGS_IGNORED="usr/bin/kitten" # written in Go
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ cd "${S}" || die
+ edo go mod vendor
+ else
+ use verify-sig &&
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # sed unfortunately feels easier on maintenance than patches here
+ local sedargs=(
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/"
+ -e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//'
+ -e "s/ld_flags.append('-[sw]')/pass/"
+ )
+
+ # kitty is often popular on wayland-only setups, try to allow this
+ use !X && sedargs+=( -e '/gl_libs =/s/=.*/= []/' ) #857918
+ use !X || use !wayland &&
+ sedargs+=( -e "s/'x11 wayland'/'$(usex X x11 wayland)'/" )
+
+ # skip docs for live version, missing dependencies
+ [[ ${PV} == 9999 ]] && sedargs+=( -e '/exists.*_build/,/docs(ddir)/d' )
+
+ sed -i setup.py "${sedargs[@]}" || die
+
+ local skiptests=(
+ # relies on 'who' command which doesn't detect users with pid-sandbox
+ kitty_tests/utmp.py
+ # may fail/hang depending on environment and shell initialization
+ kitty_tests/{shell_integration,ssh}.py
+ # relies on /proc/self/fd and gets confused when ran from here
+ tools/utils/tpmfile_test.go
+ )
+ use !test || rm "${skiptests[@]}" || die
+}
+
+src_compile() {
+ tc-export CC
+ local -x PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
+
+ go-env_set_compile_environment
+ local -x GOFLAGS="-p=$(makeopts_jobs) -v -x"
+ use ppc64 && [[ $(tc-endian) == big ]] || GOFLAGS+=" -buildmode=pie"
+
+ local conf=(
+ --disable-link-time-optimization
+ --ignore-compiler-warnings
+ --libdir-name=$(get_libdir)
+ --shell-integration="enabled no-rc no-sudo"
+ --update-check-interval=0
+ --verbose
+ )
+
+ edo "${EPYTHON}" setup.py linux-package "${conf[@]}"
+ use test && edo "${EPYTHON}" setup.py build-launcher "${conf[@]}"
+
+ rm -r linux-package/share/terminfo || die # provided by kitty-terminfo
+
+ if [[ ${PV} == 9999 ]]; then
+ mkdir -p linux-package/share/doc/${PF} || die
+ else
+ mv linux-package/share/doc/{${PN},${PF}} || die
+ fi
+
+ # generate default config as reference, command taken from docs/conf.rst
+ if ! tc-is-cross-compiler; then
+ linux-package/bin/kitty +runpy \
+ 'from kitty.config import *; print(commented_out_default_config())' \
+ > linux-package/share/doc/${PF}/kitty.conf || die
+ fi
+}
+
+src_test() {
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
+}
+
+src_install() {
+ edo mv linux-package "${ED}"/usr
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "audio-based terminal bell support" media-libs/libcanberra
+ optfeature "opening links from the terminal" x11-misc/xdg-utils
+}