summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-05 05:25:19 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-05 05:25:19 +0100
commiteffe4a9dee4cfbcf80a7f7e894e6749d28125fda (patch)
tree111c8eefaba4d62839ef16ba74f3e542da4de521
parentdev-python/freezegun: Bump to 1.3.1 (diff)
downloadgentoo-effe4a9dee4cfbcf80a7f7e894e6749d28125fda.tar.gz
gentoo-effe4a9dee4cfbcf80a7f7e894e6749d28125fda.tar.bz2
gentoo-effe4a9dee4cfbcf80a7f7e894e6749d28125fda.zip
dev-python/path: Bump to 16.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/path/Manifest1
-rw-r--r--dev-python/path/path-16.9.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/path/Manifest b/dev-python/path/Manifest
index 69ba5b0363c3..29d6641f2944 100644
--- a/dev-python/path/Manifest
+++ b/dev-python/path/Manifest
@@ -1 +1,2 @@
DIST path-16.7.1.tar.gz 48974 BLAKE2B a03eebbb391cf17033adce4d6b258217546e3b7494200a8ea97f756512177f1c7d7ea8155420e167cefe79b566a4240eec98d17b160478f9cb06d3fd839c28f2 SHA512 7d660373046845a5882a316051c350558527d6d8a5cd11735d38214f986c8e096f72b45f87cfec41bf6171e7845287a42e6e45535f87a01b46670eccd4013dbf
+DIST path-16.9.0.tar.gz 48850 BLAKE2B 0c5edc6538cb22543dd810a535840a235b66c51415284f00338bd1e84e63847d09235e55dd3d40a71f3b02f54d18cbbf4fa1e5a0356798cee3383666a26a441c SHA512 2d4c8e3923bc712c7901328a0406ce05c6c157664dfacb5a563a1b214ce561215398b31494865c99a77ed09c3ef63bb04a36d57a60e7c0e3dea05b1dacfdecf7
diff --git a/dev-python/path/path-16.9.0.ebuild b/dev-python/path/path-16.9.0.ebuild
new file mode 100644
index 000000000000..52a7318fd514
--- /dev/null
+++ b/dev-python/path/path-16.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="
+ https://github.com/jaraco/path/
+ https://pypi.org/project/path/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)