summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-01-27 22:13:02 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-01-27 22:59:54 +0100
commitf00322bad8c691cd5c948701ddf2b5a38e49ab61 (patch)
treef85c360b29c8561c165c32b3aa38c1414e798d7b
parentdev-ml/core_unix: add 0.15.2 (diff)
downloadgentoo-f00322bad8c691cd5c948701ddf2b5a38e49ab61.tar.gz
gentoo-f00322bad8c691cd5c948701ddf2b5a38e49ab61.tar.bz2
gentoo-f00322bad8c691cd5c948701ddf2b5a38e49ab61.zip
dev-ml/gapi-ocaml: add 0.4.3
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/gapi-ocaml/Manifest1
-rw-r--r--dev-ml/gapi-ocaml/gapi-ocaml-0.4.3.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/gapi-ocaml/Manifest b/dev-ml/gapi-ocaml/Manifest
index e804394c7889..2785e200c86c 100644
--- a/dev-ml/gapi-ocaml/Manifest
+++ b/dev-ml/gapi-ocaml/Manifest
@@ -1 +1,2 @@
DIST gapi-ocaml-0.4.2.tar.gz 466749 BLAKE2B 6a3e66618ed9a665de2892dc7657268f3bad43b871d6d761148152d61de2d988bc13b5051e39da4d1ddad0c620237c6018b87cd2303bc086c570aa879c197e4f SHA512 57d933c2d47ef7b80cb55b661f8df1b8642ff301d54f0fd1dfd4a9bc6238a4cb93a308e6918bbbc080fac146cf5fca2ccfe149d0528a63ead5e29e452c9cc427
+DIST gapi-ocaml-0.4.3.tar.gz 468450 BLAKE2B 5e9aeef8cdd49e64bedc4494dd60a867b16fe0d02945efcb9ea752a7dd71abfd2dad66354cdf61803cdaa93bfee33079b1a8427ac0279cc93961a62c87498390 SHA512 fb58910639db9d1a0f90c6f224d91af53d2c68611f3faea321db82cc4af940f54e4ae93ee20520ef4337dd1345b8c9961915a8706336a25d4e5a187adde1b2f2
diff --git a/dev-ml/gapi-ocaml/gapi-ocaml-0.4.3.ebuild b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.3.ebuild
new file mode 100644
index 000000000000..3b7a8af6966d
--- /dev/null
+++ b/dev-ml/gapi-ocaml/gapi-ocaml-0.4.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune findlib
+
+DESCRIPTION="A simple OCaml client for Google Services"
+HOMEPAGE="
+ https://opam.ocaml.org/packages/gapi-ocaml/
+ https://github.com/astrada/gapi-ocaml
+"
+
+SRC_URI="https://github.com/astrada/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt test"
+
+RDEPEND="
+ dev-ml/ocurl:=
+ >=dev-ml/ocamlnet-4.1.4:=
+ dev-ml/cryptokit:=
+ dev-ml/yojson:=
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-ml/ounit2 )
+"
+
+RESTRICT="!test? ( test )"