summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-26 21:46:20 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-26 21:46:20 +0100
commitf003317a62104a4d33e4e67f11c4a20f61248183 (patch)
tree7ffbeb6299a5009d9f525f0547afea3d519eea3d
parentdev-python/dnspython: Stabilize 1.16.0-r1 ALLARCHES (diff)
downloadgentoo-f003317a.tar.gz
gentoo-f003317a.tar.bz2
gentoo-f003317a.zip
dev-python/dnspython: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dnspython/Manifest1
-rw-r--r--dev-python/dnspython/dnspython-1.15.0-r1.ebuild41
-rw-r--r--dev-python/dnspython/dnspython-1.16.0.ebuild39
3 files changed, 0 insertions, 81 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index cb735da94cbd..72633cea41b8 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,2 +1 @@
-DIST dnspython-1.15.0.zip 252157 BLAKE2B 6766c1e69bc4225b08f3b1b3871fac2aba7ae707de5f16718798ce4d6846308500c5341f9ace1b48d3858ffc965a7295ee42cc2c35ff23ac38d71927dcaecfe9 SHA512 942f7cf083d1b0a9f03f040ceca194c38777f2e40862c388051986112b3f2a4a8426733ff46ec5a155319776e4a856412c3430b052b2f92f251f0e3260eb9bc1
DIST dnspython-1.16.0.tar.gz 167172 BLAKE2B a246684aae8651d94b4312a4b4cce2236a0c4f2289a8fe8a2bb8e81c6beddf6e81a7d54928bc50f950fde862b27e589e83fa9f7aaff7d263a6442f47fe9bb3bb SHA512 825a1815855e036ea1dfece6ec0d42242f83163960439ecba3da58d9adb85b65dda7e628cf38c386807a6c0c36aa026d5e95f7a1bdc2927aa2f6f042f873c14c
diff --git a/dev-python/dnspython/dnspython-1.15.0-r1.ebuild b/dev-python/dnspython/dnspython-1.15.0-r1.ebuild
deleted file mode 100644
index 9a67bca626a3..000000000000
--- a/dev-python/dnspython/dnspython-1.15.0-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="DNS toolkit for Python"
-HOMEPAGE="http://www.dnspython.org/ https://pypi.org/project/dnspython/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
- !dev-python/dnspython:py2
- !dev-python/dnspython:py3"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- app-arch/unzip"
-
-# For testsuite
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_test() {
- cd tests || die
- "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
- einfo "Testsuite passed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/dnspython/dnspython-1.16.0.ebuild b/dev-python/dnspython/dnspython-1.16.0.ebuild
deleted file mode 100644
index 6fe8fc07c090..000000000000
--- a/dev-python/dnspython/dnspython-1.16.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="DNS toolkit for Python"
-HOMEPAGE="http://www.dnspython.org/ https://pypi.org/project/dnspython/"
-SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
- >=dev-python/ecdsa-0.13[${PYTHON_USEDEP}]
- >=dev-python/idna-2.1[${PYTHON_USEDEP}]
- !dev-python/dnspython:py2
- !dev-python/dnspython:py3"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- cd tests || die
- "${EPYTHON}" utest.py || die "tests failed under ${EPYTHON}"
- einfo "Testsuite passed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}