summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2022-07-27 04:08:34 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-23 14:34:12 +0200
commitf011a8f478b183b84da6805263ff81b7a5415642 (patch)
tree69d54bd91b17c8072b6a05da728551d432637b1a
parentsci-astronomy/pal: Bump to 0.9.8 and EAPI 8 (diff)
downloadgentoo-f011a8f4.tar.gz
gentoo-f011a8f4.tar.bz2
gentoo-f011a8f4.zip
sci-physics/yoda: add version 1.9.6
Closes: https://github.com/gentoo/gentoo/pull/26613 Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-physics/yoda/Manifest1
-rw-r--r--sci-physics/yoda/yoda-1.9.6.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sci-physics/yoda/Manifest b/sci-physics/yoda/Manifest
index 0dfe8252bde5..d6600391198d 100644
--- a/sci-physics/yoda/Manifest
+++ b/sci-physics/yoda/Manifest
@@ -1,2 +1,3 @@
DIST YODA-1.9.0.tar.bz2 1061105 BLAKE2B 70d68d31456747fcb14e27585aae245930061b5135b8a96c8ff3fe0375175d00a1c2d24a6c1ca3f18fc8464e610ef6287184f3990e12ff3fb108def600e34189 SHA512 eb82f1df832c2124dd81e07c06f165ddf13c4c4b70fcd0113f85045e22085d82751325bc57bfbd167649580980d98a15b666de56dada639160f24682b58b2f71
DIST YODA-1.9.5.tar.bz2 1077442 BLAKE2B 010ab725c57dfab8160e0304d461dc44c140d1ce234f3b70834ee58b8f269159529122095a94e6b79ef752612a6659a17e1874fda2941cfbcec1f53802916b6a SHA512 46e30b33d369f5d28ec228b71eaa298f3010cc06fe568785c74bbaf3d7468c26738cc2ee40da9bcc54d978f394187a2ee9289197283c86a3358583a3c0ecd247
+DIST YODA-1.9.6.tar.bz2 1069530 BLAKE2B 23d782723c5b2429e9e9a70abe8dbf3d58a2204437a46b6e2e196cacc9b6ce55464d5600dd53492f43801866fc7da0e82d1e765cc04c493f40b2da95413aba25 SHA512 2433f2d685ccc97aa41e5f44e0c7ca560de01e3b746f2e4837ee6259cd142106e9aa0066aaa106e5298f8d4d9df3a09f5a2d058d6b1593792c9afe06b65d1a22
diff --git a/sci-physics/yoda/yoda-1.9.6.ebuild b/sci-physics/yoda/yoda-1.9.6.ebuild
new file mode 100644
index 000000000000..5802ef26d25b
--- /dev/null
+++ b/sci-physics/yoda/yoda-1.9.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 autotools python-single-r1
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="https://yoda.hepforge.org/"
+SRC_URI="https://yoda.hepforge.org/downloads?f=${P^^}.tar.bz2 -> ${P^^}.tar.bz2"
+S="${WORKDIR}/${P^^}"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="root python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) root? ( python )"
+
+RDEPEND="
+ root? ( sci-physics/root:=[${PYTHON_SINGLE_USEDEP}] )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # reconf due to python3_10 patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable root) \
+ $(use_enable python pyext)
+}
+
+src_test() {
+ # PYTESTS and SHTESTS both require python tools to be installed already
+ emake check PYTESTS= SHTESTS=
+}
+
+src_install() {
+ # prevent double installation of python library
+ emake install DESTDIR="${ED}"
+ find "${ED}" -name '*.la' -delete || die
+ newbashcomp "${ED}"/etc/bash_completion.d/${PN}-completion yoda
+ python_optimize
+ rm "${ED}"/etc/bash_completion.d/${PN}-completion || die
+}