summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-26 02:42:36 +0000
committerSam James <sam@gentoo.org>2022-02-26 02:43:35 +0000
commitf017a49dbc8dda50bb125667a1340ac80c34e330 (patch)
treea220123a8a590eba5d5332b53bf1ef7bb789e6ed
parentapp-crypt/ima-evm-utils: Bump to 1.4 (diff)
downloadgentoo-f017a49d.tar.gz
gentoo-f017a49d.tar.bz2
gentoo-f017a49d.zip
app-crypt/ima-evm-utils: sync live ebuild
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-crypt/ima-evm-utils/ima-evm-utils-1.4.ebuild4
-rw-r--r--app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild18
2 files changed, 14 insertions, 8 deletions
diff --git a/app-crypt/ima-evm-utils/ima-evm-utils-1.4.ebuild b/app-crypt/ima-evm-utils/ima-evm-utils-1.4.ebuild
index 8a6872dda3e1..3f32ba3defbf 100644
--- a/app-crypt/ima-evm-utils/ima-evm-utils-1.4.ebuild
+++ b/app-crypt/ima-evm-utils/ima-evm-utils-1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,7 +31,7 @@ PATCHES=(
"${FILESDIR}/${PN}-1.4-configure-remove-automagic-TSS-dependencies.patch"
"${FILESDIR}/${PN}-1.4-test-Rename-bash-variable-WORKDIR-to-MYWORKDIR.patch"
"${FILESDIR}/${PN}-1.4-test-remove-boot_aggregate.patch"
- )
+)
src_prepare() {
default
diff --git a/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild b/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
index bdb4d49d4f72..7237825ff877 100644
--- a/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
+++ b/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools git-r3
@@ -11,11 +11,12 @@ EGIT_REPO_URI="https://git.code.sf.net/p/linux-ima/ima-evm-utils"
LICENSE="GPL-2"
SLOT="0"
-IUSE="debug test"
+IUSE="debug test tpm"
RDEPEND="
dev-libs/openssl:0=
- sys-apps/keyutils:="
+ sys-apps/keyutils:=
+ tpm? ( app-crypt/tpm2-tss )"
DEPEND="${RDEPEND}"
BDEPEND="
app-text/asciidoc
@@ -25,18 +26,23 @@ BDEPEND="
RESTRICT="!test? ( test )"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4-configure-remove-automagic-TSS-dependencies.patch"
+ "${FILESDIR}/${PN}-1.4-test-Rename-bash-variable-WORKDIR-to-MYWORKDIR.patch"
+ "${FILESDIR}/${PN}-1.4-test-remove-boot_aggregate.patch"
+)
+
src_prepare() {
default
sed -i '/^MANPAGE_DOCBOOK_XSL/s:/usr/share/xml/docbook/stylesheet/docbook-xsl/manpages/docbook.xsl:/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl:' Makefile.am || die
-
eautoreconf
}
src_configure() {
econf \
$(use_enable debug) \
- --disable-static
+ $(use_with tpm pcrtss)
}
src_install() {