summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-15 01:04:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-15 01:35:55 +0100
commitf03381094d5a1f90a77937db8cc78e5c806ee54f (patch)
treeafc6586947f099b02823bedf2479a94a2f8c31c2
parentmedia-plugins/audacious-plugins: Add USE streamtuner (diff)
downloadgentoo-f0338109.tar.gz
gentoo-f0338109.tar.bz2
gentoo-f0338109.zip
media-plugins/audacious-plugins: Move ewarn to pkg_setup
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-plugins/audacious-plugins/audacious-plugins-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild b/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
index 02a3be387140..940ec18ab531 100644
--- a/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
+++ b/media-plugins/audacious-plugins/audacious-plugins-9999.ebuild
@@ -113,6 +113,10 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ use mp3 || ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
+}
+
src_prepare() {
default
if ! use nls; then
@@ -122,8 +126,6 @@ src_prepare() {
}
src_configure() {
- use mp3 || ewarn "MP3 support is optional, you may want to enable the mp3 USE-flag"
-
local myeconfargs=(
--enable-mpris2
--enable-songchange