summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-25 14:13:56 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-25 14:25:36 +0100
commitf035ccfa49897a9287736e3078da24c0faf20e48 (patch)
treee3b83f563f8268bad23adf52632bfdefe4483113
parentmedia-libs/pnglite: update EAPI 5 -> 8 (diff)
downloadgentoo-f035ccfa.tar.gz
gentoo-f035ccfa.tar.bz2
gentoo-f035ccfa.zip
kde-apps/ark: Add missing test BDEPEND, skip segfaulting/hanging test
plugins-clirartest requires app-arch/rar. kerfuffle-addtoarchivetest may segfault or hang indefinitely. Bug: https://bugs.gentoo.org/822177 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/ark/ark-21.08.3.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/kde-apps/ark/ark-21.08.3.ebuild b/kde-apps/ark/ark-21.08.3.ebuild
index 6d0cf94f6acc..40ed06b503e5 100644
--- a/kde-apps/ark/ark-21.08.3.ebuild
+++ b/kde-apps/ark/ark-21.08.3.ebuild
@@ -48,6 +48,7 @@ DEPEND="${RDEPEND}
"
BDEPEND="
sys-devel/gettext
+ test? ( app-arch/rar )
"
src_configure() {
@@ -58,6 +59,15 @@ src_configure() {
ecm_src_configure
}
+src_test() {
+ local myctestargs=(
+ # bug 822177: may segfault or hang indefinitely
+ -E "(kerfuffle-addtoarchivetest)"
+ )
+
+ ecm_src_test
+}
+
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "rar archive creation/extraction" app-arch/rar