summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-26 09:07:17 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-26 09:08:28 +0200
commitf0549f6e640efb07f3afb92378fb27080f22e58e (patch)
tree3b3fe77d43635cbc3097b2f621aef639a9f71b16
parentdev-python/zict: add python-3.6 (diff)
downloadgentoo-f0549f6e.tar.gz
gentoo-f0549f6e.tar.bz2
gentoo-f0549f6e.zip
dev-libs/jsoncpp: Bump to 1.8.1
-rw-r--r--dev-libs/jsoncpp/Manifest1
-rw-r--r--dev-libs/jsoncpp/jsoncpp-1.8.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/jsoncpp/Manifest b/dev-libs/jsoncpp/Manifest
index 005b389d6e89..aef861db0a11 100644
--- a/dev-libs/jsoncpp/Manifest
+++ b/dev-libs/jsoncpp/Manifest
@@ -1,3 +1,4 @@
DIST jsoncpp-0.10.2.tar.gz 197188 SHA256 37bb72615018522bb78a5eb425b36dfc79e049c1d5471b724f7ccadeac0ed479 SHA512 8e451e3ba37094445ab098d5b9f7236ac84e2f15d98e2039c565e609b757c2383e91850bd86aca507ca5cd2f733fedc484bb7760eeeee7fe9bace71d97ae0d2e WHIRLPOOL 85f9861e77a7c3cecd5e859adde832b7f12a0c5eae04ecbee203e5d8c4b8b13ba034b4aa6b78a3b981aa392a4ea6a26c2e1d411ae97768d7ed422f71ec2e5d79
DIST jsoncpp-0.10.6.tar.gz 200213 SHA256 7c285fc40ad0c113e436a1271c4e38b5017b5c7782c306e90be9d6b2ffa90212 SHA512 9fcf584d14c31fc135c9789b36c02c5985daecc7396eb21912d5ea3e757d1fd0d516d7a060e14b4955c73f6b4aa256529281da908726919236fa65310de9f1aa WHIRLPOOL f06b804045250b205f8ca1ed6fd5504cb5e18243df16c9c255310a631d6d88f78bfd8c59e31360c1e50ccabcf5b295a095a80cdbb4e0ca5a0da54a64ff8e7919
DIST jsoncpp-1.8.0.tar.gz 206659 SHA256 5deb2462cbf0c0121c9d6c9823ec72fe71417e34242e3509bc7c003d526465bc SHA512 bd0aa56827932e5b50231216c9f501da12053bf9eed6e83210b5c52afb9aff610e71995446a7e2f5f4580ff37762956a307867d3eaa1aebd6ca31e574c9e4d4c WHIRLPOOL 76bb44fc8e838a544415b802188dec19aa14cf65d41833dd7e737a8fd1e442d4566f57c505ab4a11c07a7af2f03a8053e217988882cb581b535fce55fc8e76fc
+DIST jsoncpp-1.8.1.tar.gz 210629 SHA256 858db2faf348f89fdf1062bd3e79256772e897e7f17df73e0624edf004f2f9ac SHA512 4203826fca4c366b51d28ffc928399c914ffaba8be1cada64ff118b5742e6b469d3fc3e59344587d851447857b479794c5697d4fd11a9a55b32a3a7a801b745b WHIRLPOOL fad9803f2fdc4aba2efc235b1e6a4edab3ca19b6f0ca6a275170afb477adfdad1b1bace48dfc2424d78b6f7a2ff080987298119b1797559159197a7c268a89bb
diff --git a/dev-libs/jsoncpp/jsoncpp-1.8.1.ebuild b/dev-libs/jsoncpp/jsoncpp-1.8.1.ebuild
new file mode 100644
index 000000000000..603c2d1926bf
--- /dev/null
+++ b/dev-libs/jsoncpp/jsoncpp-1.8.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-any-r1
+
+DESCRIPTION="C++ JSON reader and writer"
+HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
+SRC_URI="https://github.com/open-source-parsers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( public-domain MIT )"
+SLOT="0/11"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE="doc test"
+
+DEPEND="
+ doc? (
+ app-doc/doxygen
+ ${PYTHON_DEPS}
+ )
+ test? (
+ ${PYTHON_DEPS}
+ )"
+RDEPEND=""
+
+RESTRICT="!test? ( test )"
+
+pkg_setup() {
+ if use doc || use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DJSONCPP_WITH_TESTS=$(usex test)
+ -DJSONCPP_WITH_POST_BUILD_UNITTEST=OFF
+ -DJSONCPP_WITH_CMAKE_PACKAGE=ON
+
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_STATIC_LIBS=OFF
+
+ # Follow Debian, Ubuntu, Arch convention for headers location
+ # bug #452234
+ -DCMAKE_INSTALL_INCLUDEDIR=include/jsoncpp
+
+ # Disable implicit ccache use
+ -DCCACHE_FOUND=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc; then
+ "${EPYTHON}" doxybuild.py --doxygen="${EPREFIX}"/usr/bin/doxygen || die
+ HTML_DOCS=( dist/doxygen/jsoncpp*/. )
+ fi
+}
+
+src_test() {
+ cmake-utils_src_make jsoncpp_check
+}