summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-01 02:15:13 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-01 02:46:57 -0400
commitf06ee4edb1cf699590a39b1bdc86e84eb73edf7c (patch)
tree64bcdc20d5838eeba24128a4e921bd5fb4647464
parentgui-libs/egl-wayland: drop 1.1.10-r1 (diff)
downloadgentoo-f06ee4ed.tar.gz
gentoo-f06ee4ed.tar.bz2
gentoo-f06ee4ed.zip
gui-libs/egl-wayland: add 1.1.11
Nearly identical to previous snapshot, but properly tagged. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--gui-libs/egl-wayland/Manifest1
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.11.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/gui-libs/egl-wayland/Manifest b/gui-libs/egl-wayland/Manifest
index 93cb058a71af..c7f5f78db09f 100644
--- a/gui-libs/egl-wayland/Manifest
+++ b/gui-libs/egl-wayland/Manifest
@@ -1,3 +1,4 @@
DIST egl-wayland-1.1.10_p20220805.tar.gz 60283 BLAKE2B 14c272e4cc084892cc9eb822b85168e420c7cfd5472c9f24fd9aa6cc6a5aef2c75411c8c06e148c48e45c6ee4aa3179784b9e432905f41753840bf1ef576e634 SHA512 ce7aa6cc738dc392dfa9a6cf2c24253968404e011b4e921c6e3bf723fd4bc0eae63ef2050bef025a0726601e5ce2a08987293fd1674fb6c6b6c207969fd15bcb
+DIST egl-wayland-1.1.11.tar.gz 60459 BLAKE2B 3b9bb4da117da2494bc07667fcab56dba8fafc32b6a4f68ad85ffefd37087f67372852d8320d3a47dc83c9cb85173774d77d53873e4a016a138cd6ca68a1ffb9 SHA512 a9bb3e284cf1c90358ec7569cc7a9d01509b640e1313033116d0f10c18f9cbc5eb9d7f8aadfc3613beaa0c1d7c074ba32721f1f85f3e103c2dd1e3be7bf97f72
DIST egl-wayland-1.1.7.tar.gz 48681 BLAKE2B eebbd0e36045c50b39ef70292156f5cd137a51af2169b56a35d318d90ade3d4a5b94206d86246d52fda0c6c093ff25e389b1a3ccbe60595dc9661d199e30f33b SHA512 edc81d9f2c617587044d5f9d35b3e355db8544e8fa1d861c1b92a5a11bc1af7d994ca8abd49ce6f462a1971f20296b4c757bdf1df0d2bfc981cdafaa839f12af
DIST egl-wayland-1.1.9_p20211123.tar.gz 58900 BLAKE2B a5a08df06e302b573f1036264495e7b29ec4d3def9be0e9b8037206a42aab5c18d78b79cc3f3ffeede9708916e644f8090fadf34318429cf0040c3623da28ce1 SHA512 8de18c8c0c38ca672688a5197be20534cc90b0fecae9ea2f3d3bc851d5b50d3f148a4ce97b835a9576251c8273ea21f82f2c9694cf2b7bba28fa3b53850c43b2
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.11.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.11.ebuild
new file mode 100644
index 000000000000..15f3bab74424
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.11.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="EGLStream-based Wayland external platform"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland"
+SRC_URI="https://github.com/NVIDIA/egl-wayland/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-libs/wayland
+ !<x11-drivers/nvidia-drivers-470.57.02[wayland(-)]"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+ gui-libs/eglexternalplatform
+ >=media-libs/libglvnd-1.3.4
+ x11-libs/libdrm"
+BDEPEND="dev-util/wayland-scanner"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-remove-werror.patch
+)
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/10_nvidia_wayland.json
+}
+
+pkg_postinst() {
+ if has_version "<x11-drivers/nvidia-drivers-391"; then
+ ewarn "<=nvidia-drivers-390.xx may not work properly with this version of"
+ ewarn "egl-wayland, it is recommended to use nouveau drivers for wayland."
+ fi
+}