summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2021-03-21 17:47:31 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2021-03-21 17:53:56 +0100
commitf08bed278a8c8c0904d4f015af08509b3792e299 (patch)
treea428f3ecf116fae1b08ef56db23e15a254402b15
parentmedia-video/vdr: cleanup old (diff)
downloadgentoo-f08bed278a8c8c0904d4f015af08509b3792e299.tar.gz
gentoo-f08bed278a8c8c0904d4f015af08509b3792e299.tar.bz2
gentoo-f08bed278a8c8c0904d4f015af08509b3792e299.zip
media-plugins/vdr-live: version bump
this version has a new maintainer team and Homepage on github version is addapted to tntnet-3.x ebuild simplifyed in ssh key install routine call ar directly fixed Closes: https://bugs.gentoo.org/775755 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
-rw-r--r--media-plugins/vdr-live/Manifest1
-rw-r--r--media-plugins/vdr-live/vdr-live-3.0.6.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/media-plugins/vdr-live/Manifest b/media-plugins/vdr-live/Manifest
index 67287d836a53..3f7b768efc03 100644
--- a/media-plugins/vdr-live/Manifest
+++ b/media-plugins/vdr-live/Manifest
@@ -1,2 +1,3 @@
DIST vdr-live-0.3.0_p20130504.tar.bz2 6348021 BLAKE2B 64567a037dd283d005727b993053609e7c46784de67bcbd9afb4f68edd03cec494e6eca6c497ac578928de92c1d21b2519867c014cfd11ace79e957fc5d487d1 SHA512 7a238a4567f90448b7813366dbdb5112ab98079fd5a2c9d59d09273853fd62ad520ca9ad373704a8888eb7c25119772421fe998d87069647c40d6d2d869e09c1
DIST vdr-live-2.3.1.tar.bz2 703327 BLAKE2B 70724894a4abf2f94d682602d722b3d015cefefa7c9daf2dae35fc84bff1d950539c916d6d97e39565e87e8e7d841277ad14e137238026b25f73b1b288fa18f5 SHA512 f943c2aa477ca943b2015eb0b49a650e5c9e5cc124549b68d36b56a0ae6344a8d32ac3c4f213ab3cb91794ae569d3ed14a84168f45bf395e90536992078bce41
+DIST vdr-live-3.0.6.tar.gz 737583 BLAKE2B e9fd7f95df7c3fcd11e9e63131c948c1d318e2bb0c5cbc2fab950abc2889df8ca8a33b71f5394b3c22c45f81ee1faf1bf71ca889ae64173be8965db6f6fbd8ac SHA512 f60cd14c3a02eeb571ffc181dabd83dd0af0595d378ed34bc9cee1d54b560d74027c758d3b4d69541a71dc6f94b5f64e3972fc51aeb5a9d688be7656636bcf98
diff --git a/media-plugins/vdr-live/vdr-live-3.0.6.ebuild b/media-plugins/vdr-live/vdr-live-3.0.6.ebuild
new file mode 100644
index 000000000000..bf9d15de67ff
--- /dev/null
+++ b/media-plugins/vdr-live/vdr-live-3.0.6.ebuild
@@ -0,0 +1,94 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit ssl-cert vdr-plugin-2
+
+MY_P="v3.0.6"
+
+DESCRIPTION="VDR Plugin: Web Access To Settings"
+HOMEPAGE="https://github.com/MarkusEh/vdr-plugin-live"
+SRC_URI="https://github.com/MarkusEh/vdr-plugin-live/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2+ RSA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pcre ssl"
+
+DEPEND="media-video/vdr
+ >=dev-libs/tntnet-3[ssl=]
+ >=dev-libs/cxxtools-3
+ pcre? ( >=dev-libs/libpcre-8.12[cxx] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/vdr-plugin-live-${PV}"
+
+VDR_CONFD_FILE="${FILESDIR}/confd-2.3"
+VDR_RCADDON_FILE="${FILESDIR}/rc-addon-2.3.sh"
+
+KEEP_I18NOBJECT="yes"
+
+make_live_cert() {
+ # TODO: still true?
+ # ssl-cert eclass creates a "invalid" cert, create our own one
+ local base=$(get_base 1)
+ local keydir="/etc/vdr/plugins/live"
+
+ SSL_ORGANIZATION="${SSL_ORGANIZATION:-VDR Plugin Live}"
+ SSL_COMMONNAME="${SSL_COMMONNAME:-`hostname -f`}"
+
+ echo
+ gen_cnf || return 1
+ echo
+ gen_key 1 || return 1
+ gen_csr 1 || return 1
+ gen_crt 1 || return 1
+ echo
+
+ install -d "${ROOT}${keydir}"
+ install -m0400 "${base}.key" "${ROOT}${keydir}/live-key.pem"
+ install -m0444 "${base}.crt" "${ROOT}${keydir}/live.pem"
+
+ chown vdr:vdr "${ROOT}${keydir}/live.pem"
+ chown vdr:vdr "${ROOT}${keydir}/live-key.pem"
+}
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ if ! use pcre; then
+ sed -i "s:^HAVE_LIBPCRECPP:#HAVE_LIBPCRECPP:" Makefile || die
+ fi
+
+ # do not call ar directly
+ export _VDRAR="$(tc-getAR)"
+ sed -e "s:\$(AR):\$(_VDRAR):" \
+ -i css/Makefile \
+ -i javascript/Makefile || die
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /usr/share/vdr/plugins/live
+ doins -r live/*
+
+ fowners -R vdr:vdr /usr/share/vdr/plugins/live
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ elog "To be able to use all functions of vdr-live"
+ elog "you should emerge and enable"
+ elog "media-plugins/vdr-epgsearch to search the EPG,"
+ elog "media-plugins/vdr-streamdev for Live-TV streaming"
+
+ elog "The default username/password is:"
+ elog "\tadmin:live"
+
+ if use ssl ; then
+ make_live_cert
+ fi
+}