summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-17 11:36:20 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-17 11:36:20 +0200
commitf08eccee4f5903ebe00e14250e73744eee5f6a17 (patch)
treee0868c2b331ffabbcd3e4460fa0bb1a11dd6255d
parentdev-python/pallets-sphinx-themes: Remove old (diff)
downloadgentoo-f08eccee4f5903ebe00e14250e73744eee5f6a17.tar.gz
gentoo-f08eccee4f5903ebe00e14250e73744eee5f6a17.tar.bz2
gentoo-f08eccee4f5903ebe00e14250e73744eee5f6a17.zip
dev-python/google-api-core: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-core/Manifest1
-rw-r--r--dev-python/google-api-core/google-api-core-2.18.0.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index 052908d22983..a1587205461d 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,2 +1 @@
-DIST python-api-core-2.18.0.gh.tar.gz 210938 BLAKE2B 39ccceb2d5722cb4121ba2007cb171e703e97c57d31dd85a6f540f8b0316281255f563b43c1acd6159e6d59b8609603ca9202c9f46b5c86127a9ff0cf3874c19 SHA512 fe57eb8465c1dfe6d83abd73b0c621da49e7e0687afa59f5d4c1c7022cb8a912734859e5895781c239cfe6053ebdbea2dcf55ef6eac371b8ea58fdf0c7c398d5
DIST python-api-core-2.19.0.gh.tar.gz 210832 BLAKE2B 89947f8e8bda6de96c1778788e72f88c85d7781c4bf3c7fa08b67cd0e9b40e5774a57a5772add9c724a1bddab9ad514ddc605035289466a5648393ca57854321 SHA512 e8fb94428c3d49dcf760a0b9a471fa7fe3d149ebb11f8c12c16a0f68aaf736c5a8553d628834b4456d2419c40cc30010449ae58026271c32bbd32f67857ba31b
diff --git a/dev-python/google-api-core/google-api-core-2.18.0.ebuild b/dev-python/google-api-core/google-api-core-2.18.0.ebuild
deleted file mode 100644
index 9b9d4cf25536..000000000000
--- a/dev-python/google-api-core/google-api-core-2.18.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=python-api-core-${PV}
-DESCRIPTION="Core Library for Google Client Libraries"
-HOMEPAGE="
- https://github.com/googleapis/python-api-core/
- https://pypi.org/project/google-api-core/
- https://googleapis.dev/python/google-api-core/latest/index.html
-"
-SRC_URI="
- https://github.com/googleapis/python-api-core/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-
-RDEPEND="
- >=dev-python/googleapis-common-protos-1.56.2[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
- >=dev-python/proto-plus-1.22.3[${PYTHON_USEDEP}]
- >=dev-python/protobuf-python-3.19.5[${PYTHON_USEDEP}]
- >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
- <dev-python/requests-3[${PYTHON_USEDEP}]
- !dev-python/namespace-google
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/rsa[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # failing due to missing grpcio-status
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
- tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
- tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
- tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
- tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
-)
-
-python_test() {
- rm -rf google || die
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p asyncio tests
-}