summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-23 19:49:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-23 21:25:41 +0200
commitf094508f7743761f3c3f72d9fa327353f800ae3e (patch)
tree53b4cfd9d1da3694f5feaf451b2f5bd9a29f2db3
parentvirtual/dist-kernel: Bump to 6.4.12 (diff)
downloadgentoo-f094508f7743761f3c3f72d9fa327353f800ae3e.tar.gz
gentoo-f094508f7743761f3c3f72d9fa327353f800ae3e.tar.bz2
gentoo-f094508f7743761f3c3f72d9fa327353f800ae3e.zip
dev-python/gpep517: Bump to v14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/gpep517/Manifest1
-rw-r--r--dev-python/gpep517/gpep517-14.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/gpep517/Manifest b/dev-python/gpep517/Manifest
index 6512e80886b6..82bb81402bc8 100644
--- a/dev-python/gpep517/Manifest
+++ b/dev-python/gpep517/Manifest
@@ -1 +1,2 @@
DIST gpep517-13.gh.tar.gz 17197 BLAKE2B eb2f1061c0d762ec5cedf042c41a04eb1ddfbb146b5d81727f7e09d55e76323ee4ffb00e8a8c17a8d423b863bd46dc79a03048da1998cf50fee45bc75c64f38e SHA512 23219a3f7369def01e41fe6bbf96400cc85bb6f5efae3924451a5f3dbed0c9a5e7bb69aa1810897597aa248aa64fc6445fb32ed5bf314d0265c5339893ea58e3
+DIST gpep517-14.gh.tar.gz 17896 BLAKE2B 53e903a8efd6dc2a861784093c078cc8196ac870cc837714e5afc69afaf6494484d7614039032db4f765d6a30b6e8f639a6f6870812b24effac208d668edd0b5 SHA512 9d2c55775c19fb8a071336749fa7b0c15a25c19af380999cffd4e23b6b4bbfca1d8b1b21ed4e57c89836d2fad527b18a7ba33ba4e06c78deeec68f071e4d2375
diff --git a/dev-python/gpep517/gpep517-14.ebuild b/dev-python/gpep517/gpep517-14.ebuild
new file mode 100644
index 000000000000..75da542d1341
--- /dev/null
+++ b/dev-python/gpep517/gpep517-14.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A backend script to aid installing Python packages in Gentoo"
+HOMEPAGE="
+ https://pypi.org/project/gpep517/
+ https://github.com/projg2/gpep517/
+"
+SRC_URI="
+ https://github.com/projg2/gpep517/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/installer-0.5.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+
+distutils_enable_tests pytest
+
+python_install() {
+ python_domodule gpep517
+ python_newscript - gpep517 <<-EOF
+ #!${EPREFIX}/usr/bin/python
+ import sys
+ from gpep517.__main__ import main
+ sys.exit(main())
+ EOF
+}