summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-19 06:47:41 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-19 06:57:54 +0200
commitf0e6d11d203501522b807280a6bd5fcb4ce69ea1 (patch)
treead427627cc795432819765eabefad8fedee3bce3
parentdev-python/tekore: Bump to 5.0.0 (diff)
downloadgentoo-f0e6d11d203501522b807280a6bd5fcb4ce69ea1.tar.gz
gentoo-f0e6d11d203501522b807280a6bd5fcb4ce69ea1.tar.bz2
gentoo-f0e6d11d203501522b807280a6bd5fcb4ce69ea1.zip
dev-python/pytools: Bump to 2023.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytools/Manifest1
-rw-r--r--dev-python/pytools/pytools-2023.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytools/Manifest b/dev-python/pytools/Manifest
index e2c08a5025a1..e6186de5954f 100644
--- a/dev-python/pytools/Manifest
+++ b/dev-python/pytools/Manifest
@@ -1 +1,2 @@
DIST pytools-2022.1.14.tar.gz 74636 BLAKE2B 5f3014c0adef3571c22b93c1dec1e4b49d48a0a0b9d320e7fa8f9712aaad04383222814770ab324b7d6e028d4b2a94698e6ea1f2f7fb89a654d7c8b371634dc7 SHA512 3e733d54176b135b69ac9c76ac7816463c5c874f3e1cede522ab2901250822c821fd325d0d2e5f2b124aeabb93386d8c68e3c6e1b11f6119bed7953ec80f9d4d
+DIST pytools-2023.1.tar.gz 75361 BLAKE2B 79c3439587624e9d236e6afd8ab2effa66ebc18c5f297db6bfebaf40dbe139de4851fa29d7741b064260041491a6693201583186a361994a8997eaaa221fffb2 SHA512 1d035f8b5e155def84d084926ab43b7e4c634cf7b2cd3e3914513360570bf87da059c8109e0257797dbe84c4bc36af559c805b252c863f2145113ff681eb5974
diff --git a/dev-python/pytools/pytools-2023.1.ebuild b/dev-python/pytools/pytools-2023.1.ebuild
new file mode 100644
index 000000000000..a0307d3d551f
--- /dev/null
+++ b/dev-python/pytools/pytools-2023.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of tools missing from the Python standard library"
+HOMEPAGE="
+ https://mathema.tician.de/software/pytools/
+ https://github.com/inducer/pytools/
+ https://pypi.org/project/pytools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+# NB: numpy is now an "extra" (optional) dep -- we can remove it from
+# RDEPEND If revdeps don't need it
+RDEPEND="
+ >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+
+distutils_enable_tests pytest