summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-07 13:19:37 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-07 13:20:55 +0200
commitf0ff4c34b28d838829f419776c6726f122509299 (patch)
tree2b5b6cb8be9e444cad3c02312dc699e7c53eb2e3
parentx11-wm/herbstluftwm: Depend on x11-libs/libXrandr (diff)
downloadgentoo-f0ff4c34b28d838829f419776c6726f122509299.tar.gz
gentoo-f0ff4c34b28d838829f419776c6726f122509299.tar.bz2
gentoo-f0ff4c34b28d838829f419776c6726f122509299.zip
dev-python/matplotlib: Fix flaky usage and test deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/matplotlib/matplotlib-3.2.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/matplotlib/matplotlib-3.2.1.ebuild b/dev-python/matplotlib/matplotlib-3.2.1.ebuild
index 1d0da114a2c0..73d88adfdbe7 100644
--- a/dev-python/matplotlib/matplotlib-3.2.1.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.2.1.ebuild
@@ -89,6 +89,7 @@ BDEPEND="
>=media-gfx/graphviz-2.42.3[cairo]
)
test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pygobject:3[cairo?,${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
@@ -99,7 +100,7 @@ BDEPEND="
# Other than that, the ebuild shall be fit for out-of-source build.
DISTUTILS_IN_SOURCE_BUILD=1
-distutils_enable_tests nose
+distutils_enable_tests pytest
pkg_setup() {
unset DISPLAY # bug #278524
@@ -139,6 +140,9 @@ python_prepare_all() {
-i lib/matplotlib/{mathtext,fontconfig_pattern}.py \
|| die "sed pyparsing failed"
+ sed -e 's:\(@pytest.mark.flaky\)(reruns=3):\1:' \
+ -i lib/matplotlib/tests/test_*.py || die
+
hprefixify setupext.py
rm -rf libqhull || die