summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-16 05:38:14 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-16 05:38:14 +0200
commitf10dd533fc52b1c9233203f3836de02ecb178cac (patch)
tree60b34acec61bb4a74c8f829d1cc05bac372513f4
parentdev-python/backrefs: Bump to 5.5 (diff)
downloadgentoo-f10dd533fc52b1c9233203f3836de02ecb178cac.tar.gz
gentoo-f10dd533fc52b1c9233203f3836de02ecb178cac.tar.bz2
gentoo-f10dd533fc52b1c9233203f3836de02ecb178cac.zip
dev-python/sphinx-autodoc-typehints: Bump to 1.23.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.23.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index e8e0c7bbcbe6..438303ce5929 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1,2 +1,3 @@
DIST sphinx-autodoc-typehints-1.22.gh.tar.gz 35429 BLAKE2B d871de3d3a37b2632e6b43dcb4ce58fbf61bdfdb225650486fdffbbfff4148770f40096815d3e6807f4d3f789c0f7f7fdfef841a3d087f0b12e65671597207e3 SHA512 9fed312b5b63dcbf0b39e226486abd687e68c26eeb7303ee3049251c7007d7c364ceb196672ac16101b1a76493e0a0a4e1d9532e54eec250720a37f0c8f77fda
DIST sphinx_autodoc_typehints-1.23.0.tar.gz 35945 BLAKE2B 4af9ddd722a1fc59d52009ef46ad7af828d826cce61e0bce260b68045d4abe3b184ffc0368b29f60eba210def8d8b3b37a5455442c156b326d4b9956c6afc32c SHA512 990db1f042913088fddf56cbc9ad5f401f7d886164c348aaf19fd1541fa1566a2d58d1c182e52d839d1dd32606ca3da1191b7062a6ed9c8f04dc6a47efaf5488
+DIST sphinx_autodoc_typehints-1.23.1.tar.gz 36243 BLAKE2B e53dc42a31e358ca1e3fbbe41a3002abd4e1f470ed259d5b0b6f8def81de91653d1cb609e44dc10409340775ca877ea394e4fba1a5f2c3a38c10ce33996e12c8 SHA512 fe10d0ae4d23a979125868fd6743b37d2f65e1297620142c13cb59b83ba242e4b45098cc580c18232be1b535f5927ba6dd401f7cd4d3a39c2aab3611a2a751ed
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.23.1.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.23.1.ebuild
new file mode 100644
index 000000000000..c12ff85ed759
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.23.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2.5[${PYTHON_USEDEP}]
+ >=dev-python/sphobjinv-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)