summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-19 23:47:19 +0000
committerSam James <sam@gentoo.org>2022-03-19 23:47:19 +0000
commitf11148a08c5a6db13b042181a02cdabed244cbb6 (patch)
tree4f42d1bca2eacc94e7c1d55e0dc499170e809c92
parentsys-process/dumb-init: [QA] fix tc-get* quoting (diff)
downloadgentoo-f11148a08c5a6db13b042181a02cdabed244cbb6.tar.gz
gentoo-f11148a08c5a6db13b042181a02cdabed244cbb6.tar.bz2
gentoo-f11148a08c5a6db13b042181a02cdabed244cbb6.zip
sys-boot/palo: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-boot/palo/palo-2.14.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-boot/palo/palo-2.14.ebuild b/sys-boot/palo/palo-2.14.ebuild
index 0a94f5679bf1..01f18fe777a1 100644
--- a/sys-boot/palo/palo-2.14.ebuild
+++ b/sys-boot/palo/palo-2.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ PATCHES=(
src_compile() {
local target
for target in '-C palo' '-C ipl' 'iplboot'; do
- emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)" LD="$(tc-getLD)" ${target}
done
}