summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-17 17:36:01 +0100
committerSam James <sam@gentoo.org>2022-04-17 17:36:01 +0100
commitf1179243cc0fa5751936c32af5274d5ffd12a659 (patch)
tree441503b5638c652e3ff32cb7f5e7654ad3bed8b9
parentdev-util/ropper: drop 1.13.6 (diff)
downloadgentoo-f1179243.tar.gz
gentoo-f1179243.tar.bz2
gentoo-f1179243.zip
dev-util/unicorn: drop 2.0.0_rc5
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/unicorn/Manifest1
-rw-r--r--dev-util/unicorn/unicorn-2.0.0_rc5.ebuild81
2 files changed, 0 insertions, 82 deletions
diff --git a/dev-util/unicorn/Manifest b/dev-util/unicorn/Manifest
index ee6494e5c5ad..300b01d9f9f5 100644
--- a/dev-util/unicorn/Manifest
+++ b/dev-util/unicorn/Manifest
@@ -1,2 +1 @@
-DIST unicorn-2.0.0_rc5.tar.gz 3808762 BLAKE2B 02a77c46e075f67df04a9fe0b5474df9f6a6c154778de3223c6ed3c475bd4658abd7b57d351a63cfa7ef5ecbadbee12a6151957b7b47b4f6741b5e4581d13c4b SHA512 3b5118e378872a50d3aa0dca01cda69b0e7b3875da7b03c1708963848c71818dd1e120df8796acace661c6b4d63813b9acc8106ce3a94c0d40c3b50677fbaacd
DIST unicorn-2.0.0_rc6.tar.gz 3968714 BLAKE2B dcb42126b8a2b9f0780977c73f5e170b5ad438c4f0eca82293e47d52575de27f18440a2d71b9cd17d7b488ae1d46c8197eabbbf7fd92f196bfb7d46c197937fd SHA512 a80a9408bc5b41b6961049849a8a63f69399325a4e4d8e41f4512173d24a837048d9ac03064bc16eb129e5f52828507baa059fda64430ec52b4f9ef339d61f0d
diff --git a/dev-util/unicorn/unicorn-2.0.0_rc5.ebuild b/dev-util/unicorn/unicorn-2.0.0_rc5.ebuild
deleted file mode 100644
index e2bdf4b08071..000000000000
--- a/dev-util/unicorn/unicorn-2.0.0_rc5.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_PV=${PV/_/-}
-
-DISTUTILS_USE_PEP517=setuptools
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{9..10} )
-inherit cmake distutils-r1
-
-DESCRIPTION="A lightweight multi-platform, multi-architecture CPU emulator framework"
-HOMEPAGE="https://www.unicorn-engine.org"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/unicorn-engine/unicorn"
-else
- SRC_URI="https://github.com/unicorn-engine/unicorn/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="BSD-2 GPL-2 LGPL-2.1"
-SLOT="0/2"
-IUSE="python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="${PYTHON_DEPS}
- dev-libs/glib:2"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-BDEPEND="virtual/pkgconfig
- python? ( ${DISTUTILS_DEPS} )"
-
-UNICORN_TARGETS="x86 arm aarch64 riscv mips sparc m68k ppc"
-
-wrap_python() {
- if use python; then
- # src_prepare
- # do not compile C extensions
- export LIBUNICORN_PATH=1
-
- pushd bindings/python >/dev/null || die
- distutils-r1_${1} "$@"
- popd >/dev/null || die
- fi
-}
-
-src_prepare() {
- # Build from sources
- rm -r bindings/python/prebuilt || die "failed to remove prebuilt files"
-
- cmake_src_prepare
- wrap_python ${FUNCNAME}
-}
-
-src_configure(){
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=OFF
- -DUNICORN_BUILD_SHARED=$(usex !static-libs)
- -DUNICORN_ARCH="${UNICORN_TARGETS}"
- )
-
- cmake_src_configure
-
- wrap_python ${FUNCNAME}
-}
-
-src_compile() {
- cmake_src_compile
-
- wrap_python ${FUNCNAME}
-}
-
-src_install() {
- cmake_src_install
-
- wrap_python ${FUNCNAME}
-}