summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-29 13:17:30 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-29 13:18:07 +0200
commitf11bfef6e9a2e6d01a42be507be96b3dbd89e265 (patch)
tree72f357c36e39e7c9b2b4e47d378333b6757ac2b4
parentdev-perl/Audio-Musepack: -r bump for EAPI7 (diff)
downloadgentoo-f11bfef6e9a2e6d01a42be507be96b3dbd89e265.tar.gz
gentoo-f11bfef6e9a2e6d01a42be507be96b3dbd89e265.tar.bz2
gentoo-f11bfef6e9a2e6d01a42be507be96b3dbd89e265.zip
dev-python/pytest-describe: Bump to 1.0.0
Closes: https://bugs.gentoo.org/719992 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-describe/Manifest1
-rw-r--r--dev-python/pytest-describe/pytest-describe-1.0.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-describe/Manifest b/dev-python/pytest-describe/Manifest
index eda2cbd4f151..bdb57c925405 100644
--- a/dev-python/pytest-describe/Manifest
+++ b/dev-python/pytest-describe/Manifest
@@ -1 +1,2 @@
DIST pytest-describe-0.11.1.tar.gz 7226 BLAKE2B 5cbe722d1187fa67424e5c932eee7fc90335e6811d7493372515b44d4210d0de4b4d8f33f1583ac1ae400d91d9fb9795b2952a56fc6c2865ab450af279e45c09 SHA512 0634f17ca36f8fa346a6001338827d70dda410376660f370ba04b8857d37e009c5e33f06baee51d1c23a13094c88850668028f5d44a09c31b40baff0bfdaf1ef
+DIST pytest-describe-1.0.0.tar.gz 8917 BLAKE2B 8608a00151273ebb22da6a297580295abbd64c7d9e90bfba9611eac3be64247be20ee43bb64ead1a3f74e65719112a94535506f4402cb7084802360609ab0173 SHA512 1cefa2911e598063b3b9dce381750d204c925cb0dde890b79745c8b4f1cf6d0349f85dc9eaf895000a6f15f45a84fb920f27c01b0af1959125fbe3716cbebbbc
diff --git a/dev-python/pytest-describe/pytest-describe-1.0.0.ebuild b/dev-python/pytest-describe/pytest-describe-1.0.0.ebuild
new file mode 100644
index 000000000000..30f9e69afae6
--- /dev/null
+++ b/dev-python/pytest-describe/pytest-describe-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Describe-style plugin for pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-describe
+ https://pypi.org/project/pytest-describe"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/pytest-2.6.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ # We need to disable some plugins because tests don't like unexpected
+ # output
+ PYTEST_ADDOPTS="-p no:flaky -p no:capturelog" pytest -vv ||
+ die "Tests failed under ${EPYTHON}"
+}