summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-04 17:11:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-04 17:11:43 +0200
commitf12a862a706430111616fb3aef2425885066f6d6 (patch)
tree51a7f0e206d5b9dcff9062d834dc02000ff597c2
parentdev-python/webcolors: Enable py3.10 (diff)
downloadgentoo-f12a862a706430111616fb3aef2425885066f6d6.tar.gz
gentoo-f12a862a706430111616fb3aef2425885066f6d6.tar.bz2
gentoo-f12a862a706430111616fb3aef2425885066f6d6.zip
dev-python/rfc3986-validator: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild b/dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild
index 7e4e0d71a72f..e3f747530485 100644
--- a/dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild
+++ b/dev-python/rfc3986-validator/rfc3986-validator-0.1.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -14,6 +14,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="Pure python RFC3986 validator"
HOMEPAGE="https://pypi.org/project/rfc3986-validator/ https://github.com/naimetti/rfc3986-validator"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
@@ -22,8 +23,6 @@ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
RDEPEND="dev-python/rfc3987[${PYTHON_USEDEP}]"
BDEPEND="test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
-S="${WORKDIR}/${MY_P}"
-
distutils_enable_tests pytest
python_prepare_all() {