summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-06 09:49:27 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-06 09:59:27 +0100
commitf12d8425f8bfed4b25f8ede65cd32da358bc531d (patch)
tree278b85cc256989ed2939331fa362724dc7b278e6
parentdev-util/stripe-mock: Add python@ as co-maint (diff)
downloadgentoo-f12d8425f8bfed4b25f8ede65cd32da358bc531d.tar.gz
gentoo-f12d8425f8bfed4b25f8ede65cd32da358bc531d.tar.bz2
gentoo-f12d8425f8bfed4b25f8ede65cd32da358bc531d.zip
dev-python/stripe: Bump to 2.55.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/stripe/Manifest1
-rw-r--r--dev-python/stripe/stripe-2.55.2.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/stripe/Manifest b/dev-python/stripe/Manifest
index 1e4b75b876ce..fd402d55cc2c 100644
--- a/dev-python/stripe/Manifest
+++ b/dev-python/stripe/Manifest
@@ -1 +1,2 @@
DIST stripe-2.46.0.tar.gz 218080 BLAKE2B 990535efd32b5ddfe166d5b6ad1cdcd966df53fe830a10938355cac10287542284a73f99332878225388a3c28ba431baf96fa4e6e745345c9fa02e64a7e33c0f SHA512 dbfa586cfe7897b32fe95b7230fca5ccb8a12b429982776ee8873878fb6b7284cbb924e8dc6031d59647cc6080115ad541fda02d320c091b6c1bb374679d2213
+DIST stripe-2.55.2.tar.gz 215652 BLAKE2B 28bf455a202df7ff7529f932eda50ed4942e72ccf0453b7ff50bcc63c4f3d2177194d2dd6a95391cc5fe7a55c26abd5ba1225fc830ebd9d23a20ebffe2b82911 SHA512 9e14edf57e394837fdc4457bded274b45c309353488adf81a5fbea67ea4c3321392c5316c9a60dfe975110791672b8e7d1dc7ae14994a320c41b1efb7f75695b
diff --git a/dev-python/stripe/stripe-2.55.2.ebuild b/dev-python/stripe/stripe-2.55.2.ebuild
new file mode 100644
index 000000000000..fcc7e8aeedc4
--- /dev/null
+++ b/dev-python/stripe/stripe-2.55.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Stripe python bindings"
+HOMEPAGE="https://github.com/stripe/stripe-python"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/requests-2.20[${PYTHON_USEDEP}]
+"
+# See https://github.com/stripe/stripe-python/blob/v2.10.1/tests/conftest.py#L17
+# for minimum required version of stripe-mock
+# Running the tests against dev-util/stripe-mock-0.47.0 resulted in test errors
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-util/stripe-mock-0.101.0
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ net-misc/curl
+ )
+"
+
+DOCS=(LONG_DESCRIPTION.rst CHANGELOG.md README.md)
+
+src_test() {
+ local stripe_mock_port=12111
+ local stripe_mock_max_port=12121
+ local stripe_mock_logfile="${T}/stripe_mock_${EPYTHON}.log"
+ # Try to start stripe-mock until we find a free port
+ while [[ "${stripe_mock_port}" -le "${stripe_mock_max_port}" ]]; do
+ ebegin "Trying to start stripe-mock on port ${stripe_mock_port}"
+ stripe-mock --http-port ${stripe_mock_port} &> "${stripe_mock_logfile}" &
+ local stripe_mock_pid=$!
+ sleep 2
+ # Did stripe-mock start?
+ curl --fail -u "sk_test_123:" \
+ http://127.0.0.1:${stripe_mock_port}/v1/customers &> /dev/null
+ eend $? "Port ${stripe_mock_port} unavailable"
+ if [[ $? -eq 0 ]]; then
+ einfo "stripe-mock running on port ${stripe_mock_port}"
+ break
+ fi
+ (( stripe_mock_port++ ))
+ done
+ if [[ "${stripe_mock_port}" -gt "${stripe_mock_max_port}" ]]; then
+ eerror "Unable to start stripe-mock for tests"
+ die "Please see the logfile located at: ${stripe_mock_logfile}"
+ fi
+
+ distutils-r1_src_test
+
+ # Tear down stripe-mock
+ kill "${stripe_mock_pid}" || die "Unable to stop stripe-mock"
+}
+
+python_test() {
+ STRIPE_MOCK_PORT=${stripe_mock_port} pytest -vv || die "Tests failed with ${EPYTHON}"
+}