summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-27 18:44:06 +0100
committerSam James <sam@gentoo.org>2023-05-28 19:10:59 +0100
commitf13a2e8a33c4771516ebb2e9feaaff527f2f1e6a (patch)
tree632142b37a41c360428f44ca5cf652e3fb6ad247
parentdev-python/constantly: enable py3.12 (diff)
downloadgentoo-f13a2e8a.tar.gz
gentoo-f13a2e8a.tar.bz2
gentoo-f13a2e8a.zip
dev-python/incremental: enable py3.12
New revision for ~loong. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/incremental/incremental-22.10.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/incremental/incremental-22.10.0-r1.ebuild b/dev-python/incremental/incremental-22.10.0-r1.ebuild
new file mode 100644
index 000000000000..b87b7a134526
--- /dev/null
+++ b/dev-python/incremental/incremental-22.10.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Incremental is a small library that versions your Python projects"
+HOMEPAGE="https://github.com/twisted/incremental https://pypi.org/project/incremental/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/twisted[${PYTHON_USEDEP}] )"
+
+python_test() {
+ "${EPYTHON}" -m twisted.trial incremental ||
+ die "Tests failed on ${EPYTHON}"
+}