summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-03-01 18:42:52 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-03-01 18:43:56 +0200
commitf13f2c80cc1dac586270f3629ec77633fb8f055e (patch)
treedb9469d9f654765b198374195e98736b00594938
parentdev-libs/libpwquality: drop usr-ldscript hacks (diff)
downloadgentoo-f13f2c80cc1dac586270f3629ec77633fb8f055e.tar.gz
gentoo-f13f2c80cc1dac586270f3629ec77633fb8f055e.tar.bz2
gentoo-f13f2c80cc1dac586270f3629ec77633fb8f055e.zip
www-client/pybugz: add 0.14, flit, add test, enable py3.12
Thanks to moving to flit upstream, the install is much simpler. Add a basic test for verifying the tools works (needs network). Enable py3.12 Remove dep on python[readline] - not used upstream. Closes: https://bugs.gentoo.org/604826 Closes: https://bugs.gentoo.org/847301 Closes: https://bugs.gentoo.org/919903 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--www-client/pybugz/Manifest1
-rw-r--r--www-client/pybugz/pybugz-0.14.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/www-client/pybugz/Manifest b/www-client/pybugz/Manifest
index ba05047de28c..e15b1c517db8 100644
--- a/www-client/pybugz/Manifest
+++ b/www-client/pybugz/Manifest
@@ -1 +1,2 @@
DIST pybugz-0.13.tar.gz 26876 BLAKE2B fbab5ff308e137bf590620362fe102408444c7c1cb375f2c2d426cf5873fba5cf8759d7083be4c6bd305191680af8d1afc3aaf0648e186a93af4dd0b60442093 SHA512 2cbbd32b44d0d513e91e5c35dca5c68e34a963190c31f9139922f6b8ba69c7362063155b35833a00c2bd064f94d99367e2941a573aed4488f9a71a3b163d4b54
+DIST pybugz-0.14.tar.gz 26589 BLAKE2B 7d18060f0398869d8420013b298fd1899b89e9136332b961b289bbc93894d020ef3c6a5af90ddc5966e14a3eb65880fa5751d15011621177ee09176148d845f9 SHA512 4701b7e67bb922f3fcf5158449a07a872723347e83ff654ce93f8f2fdb495d720bcc387b74b68429fe48beb8b2acf98ad3ce77720e99dfffaba92cbc97052cdd
diff --git a/www-client/pybugz/pybugz-0.14.ebuild b/www-client/pybugz/pybugz-0.14.ebuild
new file mode 100644
index 000000000000..6583a278f92d
--- /dev/null
+++ b/www-client/pybugz/pybugz-0.14.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="ssl(+)"
+
+if [[ ${PV} = "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/williamh/pybugz.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/williamh/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Command line interface to (Gentoo) Bugzilla"
+HOMEPAGE="https://github.com/williamh/pybugz"
+
+LICENSE="GPL-2"
+SLOT="0"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+python_test() {
+ # not the highest quality of test, but checks many parts of the code work.
+ # good enough for PYTHON_COMPAT checks.
+ "${EPYTHON}" lbugz get 784263 || die "Tests failed with ${EPYTHON}"
+}