summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-10 03:47:44 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-10 03:47:44 +0200
commitf147742995a5f4214d36a0bcd607cba6b85146bf (patch)
treefa0bea8fcb0d6b2a40fcd523cf3de016e2589ff1
parentdev-python/stevedore: Remove old (diff)
downloadgentoo-f147742995a5f4214d36a0bcd607cba6b85146bf.tar.gz
gentoo-f147742995a5f4214d36a0bcd607cba6b85146bf.tar.bz2
gentoo-f147742995a5f4214d36a0bcd607cba6b85146bf.zip
dev-python/tempest: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tempest/Manifest1
-rw-r--r--dev-python/tempest/tempest-34.2.0.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/dev-python/tempest/Manifest b/dev-python/tempest/Manifest
index 55eda873b4b5..a74318f86623 100644
--- a/dev-python/tempest/Manifest
+++ b/dev-python/tempest/Manifest
@@ -1,2 +1 @@
-DIST tempest-34.2.0.tar.gz 1141098 BLAKE2B 60d09fc0de49e63213bf23cc223cec92b53f887ff5677fd80cefac441166ef777bc8b96682847697702af26d8481192a2fe19ddbe42cd3b991cc0f16ed09176d SHA512 22cf6e5b6d60398a7a1698ad0bad02d8d16ffd815f573fb526becb9d1be64151bc6b33fb6b8b03f9c52f18565ca06cad1bf9725f2cff2c6116c88f85439b5d7e
DIST tempest-35.0.0.tar.gz 1144022 BLAKE2B dd333ac1271ef51171ff7d06931138a6de5872a86e2ed49c4d94b37431f6f94092069eef6700e453ab6e5fc04f004f5bd040af64ea98531bf56eba5edc9394b3 SHA512 c8986e13c821c8861f0b9c1b37c71a1017cd6de480a5efdcc646b51d1c7032a236f98735d0f77240fc9ec9eb711638a12f7a4a8d67e99c76bc1f6b561c39c61d
diff --git a/dev-python/tempest/tempest-34.2.0.ebuild b/dev-python/tempest/tempest-34.2.0.ebuild
deleted file mode 100644
index f7d3f5d8ad3e..000000000000
--- a/dev-python/tempest/tempest-34.2.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="OpenStack Integration Testing"
-HOMEPAGE="
- https://pypi.org/project/tempest/
- https://docs.openstack.org/tempest/latest/
- https://launchpad.net/tempest/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-RDEPEND="
- >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
- >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
- >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
- >=dev-python/fasteners-0.16.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- dev-python/stestr[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # Small subset of tests, which fail as result of not using specific
- # testing environment. Others expect to run suite using stestr.
- rm -r tempest/tests/lib/services/volume/v3/ || die
- rm tempest/tests/test_list_tests.py || die
- rm tempest/tests/lib/cmd/test_check_uuid.py || die
-
- # remove dep on hacking
- rm tempest/tests/test_hacking.py || die
-
- distutils-r1_src_prepare
-}
-
-python_compile() {
- distutils-r1_python_compile
- mv "${BUILD_DIR}"/install/{usr/,}etc || die
-}
-
-python_test() {
- local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1
- local -x OS_TEST_TIMEOUT=300
- eunittest -b -s tempest/tests -t .
-}