summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2022-11-01 15:31:38 +0300
committerConrad Kostecki <conikost@gentoo.org>2022-11-01 19:48:12 +0100
commitf14c66d1ae4971049e399e4396eba1992f434b5c (patch)
tree1631b9514ed387f8e4cfd4136db84d53bf329372
parentsys-apps/hw-probe: drop 1.6.4 (diff)
downloadgentoo-f14c66d1ae4971049e399e4396eba1992f434b5c.tar.gz
gentoo-f14c66d1ae4971049e399e4396eba1992f434b5c.tar.bz2
gentoo-f14c66d1ae4971049e399e4396eba1992f434b5c.zip
app-arch/upx: fix running tests (#878977)
Tests should runs sequentially since there no dependencies for each test step. Closes: https://bugs.gentoo.org/878977 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28076 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-arch/upx/upx-4.0.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/app-arch/upx/upx-4.0.0.ebuild b/app-arch/upx/upx-4.0.0.ebuild
index dcfcfaccee67..45118519051f 100644
--- a/app-arch/upx/upx-4.0.0.ebuild
+++ b/app-arch/upx/upx-4.0.0.ebuild
@@ -13,6 +13,15 @@ S="${WORKDIR}/${P}-src"
LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
RDEPEND="!app-arch/upx-bin"
BDEPEND="app-arch/xz-utils[extra-filters]"
+
+src_test() {
+ # Don't run tests in parallel, #878977
+ cd "${BUILD_DIR}" || die
+ ctest || die
+}