summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-11-08 09:38:15 -0500
committerMatt Turner <mattst88@gentoo.org>2020-11-08 10:13:19 -0500
commitf1620b75b12de693f1c0764b5f1f31585f221a98 (patch)
treeb79f0cd49963bea2e4acec4264db191d1ca5ff94
parentapp-admin/clsync: version bump (diff)
downloadgentoo-f1620b75b12de693f1c0764b5f1f31585f221a98.tar.gz
gentoo-f1620b75b12de693f1c0764b5f1f31585f221a98.tar.bz2
gentoo-f1620b75b12de693f1c0764b5f1f31585f221a98.zip
dev-libs/appstream-glib: Version bump to 0.7.18
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/appstream-glib/Manifest1
-rw-r--r--dev-libs/appstream-glib/appstream-glib-0.7.18.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/appstream-glib/Manifest b/dev-libs/appstream-glib/Manifest
index 00d2d6531fd5..640faab738e1 100644
--- a/dev-libs/appstream-glib/Manifest
+++ b/dev-libs/appstream-glib/Manifest
@@ -1,2 +1,3 @@
DIST appstream-glib-0.7.16.tar.xz 2243684 BLAKE2B 101a964822cc2421608e04a342b89248d16fff006c1843433f5db11703533fb7d0b2cb390d1e2f85274c51d0bd989502fc453700dfb9c32005a7b7c64cb59348 SHA512 a2991dbd26deeb1fb1daef1811c38ff5b55b2fae0bf2d8cc612c2e370613cb6b0468cf287ab3b575f6e6e3203aabcca12dd95474f70a54d6052a34dcb27b951b
DIST appstream-glib-0.7.17.tar.xz 2245372 BLAKE2B 88173b209b275962ecd4b0a5d3cc344b317dec39a57cb6ebcdbc1c4447017b69c8e68ae19e336b1780477120269deda28b7e53d935a057fac193f123d91013d0 SHA512 72eae6057a4b18b6eca34c795c2bfd982fd7a31500b70beb9553bdf8a7617a03319a2813eb93af20f2e39678ef6ee524dee48b2cbcccde0736f9d10a547ca223
+DIST appstream-glib-0.7.18.tar.xz 2309276 BLAKE2B 67f414ae45866cab314ed2b307f2045a2035c262810696246f5bdea2a0bac88d98b561f72a8e87608f90407ad6d577d720213461ecef09d277e919b5330c0bc2 SHA512 2a202eb25d823d524128a8ab164025b6579e069f8b62373cf5447d049a0e3764fca5bf1464296101a45870d1426b094493fc8ead07a6a4bcb514c0f1a91e8ff2
diff --git a/dev-libs/appstream-glib/appstream-glib-0.7.18.ebuild b/dev-libs/appstream-glib/appstream-glib-0.7.18.ebuild
new file mode 100644
index 000000000000..e78820c51e2d
--- /dev/null
+++ b/dev-libs/appstream-glib/appstream-glib-0.7.18.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg meson
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="https://people.freedesktop.org/~hughsient/appstream-glib/"
+SRC_URI="https://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/8" # soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="gtk-doc fonts +introspection stemmer"
+
+RDEPEND="
+ >=dev-libs/glib-2.58.0:2
+ sys-apps/util-linux
+ app-arch/libarchive
+ >=net-libs/libsoup-2.51.92:2.4
+ >=dev-libs/json-glib-1.1.2
+ >=x11-libs/gdk-pixbuf-2.31.5:2[introspection?]
+
+ fonts? ( x11-libs/gtk+:3
+ >=media-libs/freetype-2.4:2 )
+ >=media-libs/fontconfig-2.11:1.0
+ dev-libs/libyaml
+ stemmer? ( dev-libs/snowball-stemmer )
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-util/gperf
+
+ dev-libs/libxml2:2
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.9
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+"
+# ${PN} superseeds appdata-tools
+RDEPEND="${RDEPEND}
+ !<dev-util/appdata-tools-0.1.8-r1
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddep11=true
+ -Dbuilder=true
+ -Drpm=false
+ -Dalpm=false
+ $(meson_use fonts)
+ $(meson_use stemmer)
+ -Dman=true
+ $(meson_use gtk-doc)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}