summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-26 12:07:35 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-26 12:15:40 +0100
commitf162ac0ab6e1d9757543e382e242d668e1e79a80 (patch)
tree940c57ce66c9006e60f3cda64226b28246ce4e26
parentdev-python/argcomplete: Stabilize 1.11.0 ALLARCHES (diff)
downloadgentoo-f162ac0ab6e1d9757543e382e242d668e1e79a80.tar.gz
gentoo-f162ac0ab6e1d9757543e382e242d668e1e79a80.tar.bz2
gentoo-f162ac0ab6e1d9757543e382e242d668e1e79a80.zip
dev-python/argcomplete: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/argcomplete/Manifest2
-rw-r--r--dev-python/argcomplete/argcomplete-1.10.3.ebuild32
-rw-r--r--dev-python/argcomplete/argcomplete-1.9.4.ebuild34
3 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/argcomplete/Manifest b/dev-python/argcomplete/Manifest
index a03db52b3799..1df0358c61ea 100644
--- a/dev-python/argcomplete/Manifest
+++ b/dev-python/argcomplete/Manifest
@@ -1,4 +1,2 @@
-DIST argcomplete-1.10.3.tar.gz 50173 BLAKE2B 371baf55b65d49885398d3b2cbc2fa8abda30345643fd3f5700f92b76d4426a5f790835a83c158e47f9ee0f5fb6de8f8696528dc0701a1c8431f205bf2033703 SHA512 ea0fa18c161b395448fc09f5fad1190040ac05bb8c763c1ab775a95a10fcc88342f1b8594edcb07d56728014487f6ac54899b7e4cd16788cdc40cf14a4d60731
DIST argcomplete-1.11.0.tar.gz 50555 BLAKE2B 7029b2bf442362f3dca804b75c32e000bf48e1ccee1e8e4e0e3c484d883a95f4c4774f7367b51f6310b653be457f3ad1ee5e4907cf9566c97a12ca85fbcb177d SHA512 30a594d7f3a9ad31b4a7c537bd81e6cc23bcb3861a9d2b9999c654c0f04b4f330bcb7dbab7fe7191d4b8bbbbecdb2ad3c1b8ab812c16bec880fe83733f75c5b6
DIST argcomplete-1.11.1.tar.gz 50773 BLAKE2B 15c92929fc20a10a1f1e29cf8714b74dd9ab0ce11e7f77acd4b15a907ad885f944f8540a8b37fef13ea67ee8eb76107e1c72746434f2710ded7331830494ff50 SHA512 523d542cf1430d8ad7b056e3b9c52769847c6e0bb9e266d71cc961e56816b7811f488a5c412f89b8de0d022a321d74733af87a50b3c0d698e796fb5e322d16ce
-DIST argcomplete-1.9.4.tar.gz 47471 BLAKE2B ba64acc1fb2ae336166504db3dd991227c4e2a04abc6909ecf6723c1d2ce82ea65453ca2dde97316da9eaaa5b60026a6c8e4f3d658f1ed8122ca4fd00723fca1 SHA512 831958dffc75c65e2a63918d1e6f5e1fa47ec753b913c978e8d1d30d430ab8fedf66c99d8df23b2abc547b42c27335ccf47811224322994316ca2225c85ce346
diff --git a/dev-python/argcomplete/argcomplete-1.10.3.ebuild b/dev-python/argcomplete/argcomplete-1.10.3.ebuild
deleted file mode 100644
index c3d71aa3c8fb..000000000000
--- a/dev-python/argcomplete/argcomplete-1.10.3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Bash tab completion for argparse"
-HOMEPAGE="https://pypi.org/project/argcomplete/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# pip is called as an external tool
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- app-shells/fish
- app-shells/tcsh
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pip
- )"
-
-python_test() {
- "${EPYTHON}" test/test.py -v || die
-}
diff --git a/dev-python/argcomplete/argcomplete-1.9.4.ebuild b/dev-python/argcomplete/argcomplete-1.9.4.ebuild
deleted file mode 100644
index 65ae7e0e5033..000000000000
--- a/dev-python/argcomplete/argcomplete-1.9.4.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Bash tab completion for argparse"
-HOMEPAGE="https://pypi.org/project/argcomplete/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pexpect[${PYTHON_USEDEP}]
- app-shells/tcsh
- )"
-
-python_test() {
- "${EPYTHON}" test/test.py || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- newbashcomp "${S}"/${PN}/bash_completion.d/python-argcomplete.sh python-${PN}
-}