summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-09 19:32:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-09 19:43:20 +0100
commitf16b6740855d16c77d4c8de546e2ae68e3ed6368 (patch)
treeeb077e0e84740baf996e5b39571a2a7d569bb919
parentdev-python/colour: Rewrite the build system to fix .dist-info (diff)
downloadgentoo-f16b6740855d16c77d4c8de546e2ae68e3ed6368.tar.gz
gentoo-f16b6740855d16c77d4c8de546e2ae68e3ed6368.tar.bz2
gentoo-f16b6740855d16c77d4c8de546e2ae68e3ed6368.zip
dev-python/dulwich: Do not install docs to site-packages
Closes: https://bugs.gentoo.org/921651 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dulwich/dulwich-0.21.7-r1.ebuild (renamed from dev-python/dulwich/dulwich-0.21.7.ebuild)11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/dulwich/dulwich-0.21.7.ebuild b/dev-python/dulwich/dulwich-0.21.7-r1.ebuild
index 5ddf377dafa2..3369252c2d5f 100644
--- a/dev-python/dulwich/dulwich-0.21.7.ebuild
+++ b/dev-python/dulwich/dulwich-0.21.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -34,6 +34,15 @@ BDEPEND="
distutils_enable_sphinx docs
+src_prepare() {
+ # Do not install "docs" directory into site-packages
+ # https://github.com/jelmer/dulwich/issues/1248
+ sed -i -e '/package_data/d' setup.py || die
+ rm -r *.egg-info || die
+
+ distutils-r1_src_prepare
+}
+
python_test() {
# remove interference from the tests that do stuff like user.name
unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE