summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2016-09-24 19:38:49 +0100
committerAlice Ferrazzi <alicef@gentoo.org>2016-09-24 19:38:49 +0100
commitf16b73fc895e5e213c9e8b59db8268907cd0cb37 (patch)
treefb925b2216f00793b85ed37d2b44bcd14f082cf6
parentdev-python/paramiko: add maintainer (diff)
downloadgentoo-f16b73fc895e5e213c9e8b59db8268907cd0cb37.tar.gz
gentoo-f16b73fc895e5e213c9e8b59db8268907cd0cb37.tar.bz2
gentoo-f16b73fc895e5e213c9e8b59db8268907cd0cb37.zip
dev-python/libcloud: version bump to 1.2.1
updated copyright Package-Manager: portage-2.2.28
-rw-r--r--dev-python/libcloud/Manifest1
-rw-r--r--dev-python/libcloud/libcloud-1.2.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/libcloud/Manifest b/dev-python/libcloud/Manifest
index d951c8e17745..ab0f04f17eea 100644
--- a/dev-python/libcloud/Manifest
+++ b/dev-python/libcloud/Manifest
@@ -2,3 +2,4 @@ DIST apache-libcloud-0.14.1.tar.bz2 546545 SHA256 8562fd79c8afc63dabc8f62b08f13a
DIST apache-libcloud-0.15.0.tar.bz2 571365 SHA256 fcfea13c73279aaa846bbc6a22dad37864b2314b8497a3a4994b2b0632cf0633 SHA512 b0e85dba0a70701784903510e6eed1ada082b02e989a6af43122e3eaaaeee1cbd5da59660e1e78877219798b50f395d02d0738ae983bd1665eba0984d737e16c WHIRLPOOL eae1dd98b931ea88431d34b18325a3f62ab076d52fbeedc9ee9507234133fc1d99eed4cd24a3411e50870008aad3233f5d715341e3c2444aac29c6c3e35299ed
DIST apache-libcloud-0.15.1.tar.bz2 570953 SHA256 557e3f29e0ab1f19a31e858a8e802c822cb7f07df5edce029a1c67d2b0f30d15 SHA512 0cbc02c955cb91e135d73a5198ad216d0f91fa942b88dd1ffc1c46a487190f45500f003d2825cdb4f6c96c4ca7e5cf2681709769b0c2d8801b08e5a41b3d69b0 WHIRLPOOL 0143a7d2c337603f769bb2d3fd4fb98df18c82dfaa09c12fe481f18eb300c65d9efd4e18756d0c75a691b6d755fff0f62d41ccda3c9006955870fb8631d8366d
DIST apache-libcloud-0.17.0.tar.bz2 663406 SHA256 22a6360fccbd956398e3236dceacc469c397d0d8c0caad33352f224b352bd943 SHA512 a87d60362c43e3a1f1a4534641985d81b07ff8ad5029cd04b446fcb30cd3373471c86f62aeed75c98cbbe61d59aece50b2e8deead755535b609847ee60ce8027 WHIRLPOOL 727f0c5c2542a5357d20e587e005f7017754e6214646af170ec639c737325be0e5bbf9215d9b35ad3cc43f9edf3ecdabc93fb1907bfeff49f7fdd1073a606d27
+DIST apache-libcloud-1.2.1.tar.bz2 992983 SHA256 1f4f607855c1ff5d88dc709849e746a2213d99c6dfc7054244af8be1caf79062 SHA512 12e239f286d8eb523597488998582be02d6e8cd4e21a8fa7c639c829ba622833e4292ac4cd7cbc8b94670e19ec1711cb0032bc72433f421bf2ba2b8c70dcd954 WHIRLPOOL fb9574bfa81e08d34cbce6b96988425cf9b0aa44202397bf345383eee95e564de1427581cc3cb0095ea37912b64a40c65e1ca55383bac9a27ddce4ef63f4adbd
diff --git a/dev-python/libcloud/libcloud-1.2.1.ebuild b/dev-python/libcloud/libcloud-1.2.1.ebuild
new file mode 100644
index 000000000000..c83366bf9cb7
--- /dev/null
+++ b/dev-python/libcloud/libcloud-1.2.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# py3 dropped due to failing tests once lockfile installed
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="http://libcloud.apache.org/index.html"
+SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/lockfile[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-ssl-match-hostname[${PYTHON_USEDEP}]' python{2_7,3_4} pypy)
+ )"
+
+S="${WORKDIR}/apache-${P}"
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples
+ mv example_*.py examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}