summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-03-08 07:58:37 +0100
committerHans de Graaff <graaff@gentoo.org>2024-03-08 09:00:49 +0100
commitf17aa3f5c9629ec09cbdd39eb0d8ccf84ce2f17f (patch)
tree3bececb9594c582b9a3088be87bf16d3660f6e35
parentsci-libs/caffe2: remove test file from correct location (diff)
downloadgentoo-f17aa3f5c9629ec09cbdd39eb0d8ccf84ce2f17f.tar.gz
gentoo-f17aa3f5c9629ec09cbdd39eb0d8ccf84ce2f17f.tar.bz2
gentoo-f17aa3f5c9629ec09cbdd39eb0d8ccf84ce2f17f.zip
dev-ruby/prawn: add 2.5.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/prawn/Manifest1
-rw-r--r--dev-ruby/prawn/prawn-2.5.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/prawn/Manifest b/dev-ruby/prawn/Manifest
index d3e45e2289af..89379d489135 100644
--- a/dev-ruby/prawn/Manifest
+++ b/dev-ruby/prawn/Manifest
@@ -1 +1,2 @@
DIST prawn-2.4.0.tar.gz 5239492 BLAKE2B 5435d7715d2b3020316a04cbf2db1b7793435f2d05d34aae4832e12908a928f689c86d358562e7cd1c2675171a1743757097f0af3357eb667e4e2b9462890590 SHA512 e9fcc31ad2b5aa23592a8bf9419153fcb3080e00e53c9a91b50edc526631227fe86769eeb09336d267ea8f0a94f12336f71b24adc4d5cd9e750367d51f07c867
+DIST prawn-2.5.0.tar.gz 5254375 BLAKE2B e523522868716a3d4926cbbeb33b6d71ce8211065b66a1633e351465e9a9e5c6b62e2de066302c366964df468d6c494393c3afb011f7b91392bc6d0940e55ec9 SHA512 1feb425867c276dd4dcf27f5086c75700ef191e68a1a91756cfd4058540b268dfc29b0d249d281e7ded6e2d2bf7aa56065e6173c4c9caf4d568dc8e4ad66e08d
diff --git a/dev-ruby/prawn/prawn-2.5.0.ebuild b/dev-ruby/prawn/prawn-2.5.0.ebuild
new file mode 100644
index 000000000000..f0f67e5ce12b
--- /dev/null
+++ b/dev-ruby/prawn/prawn-2.5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_GEMSPEC="prawn.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast, Nimble PDF Generation For Ruby"
+HOMEPAGE="https://prawnpdf.org/"
+SRC_URI="https://github.com/prawnpdf/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="|| ( GPL-2 GPL-3 Ruby )"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ =dev-ruby/matrix-0.4*
+ =dev-ruby/pdf-core-0.10*
+ >=dev-ruby/ttfunk-1.8:*
+"
+ruby_add_bdepend "test? ( dev-ruby/coderay
+ >=dev-ruby/pdf-inspector-1.2.1
+ >=dev-ruby/pdf-reader-1.4
+ )"
+
+all_ruby_prepare() {
+ sed -i -e 's/__dir__/"."/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e "/[Bb]undler/d" Rakefile spec/spec_helper.rb || die
+
+ # Remove test that needs unpackaged dependency
+ rm -f spec/prawn_manual_spec.rb || die
+}