summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-25 04:04:13 +0100
committerSam James <sam@gentoo.org>2021-07-31 01:17:18 +0100
commitf17fc82cfd256723006c5afa229185d5a81c7e01 (patch)
treed8577e9b24c6439f2979c9cf565b8e49256b3bf3
parentgui-wm/sway: [QA] unconditionally install completion files (diff)
downloadgentoo-f17fc82c.tar.gz
gentoo-f17fc82c.tar.bz2
gentoo-f17fc82c.zip
net-misc/plowshare: [QA] unconditionally install completion files
QA policy [0] says that we don't conditionalise installation of small files. It's a wasteful rebuild and inconsistent across packages for when users desire completions to be available. [0] https://projects.gentoo.org/qa/policy-guide/installed-files.html#pg0301 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/plowshare/plowshare-2.1.6-r1.ebuild (renamed from net-misc/plowshare/plowshare-2.1.6.ebuild)18
-rw-r--r--net-misc/plowshare/plowshare-2.1.7-r1.ebuild (renamed from net-misc/plowshare/plowshare-2.1.7.ebuild)18
-rw-r--r--net-misc/plowshare/plowshare-9999.ebuild16
3 files changed, 12 insertions, 40 deletions
diff --git a/net-misc/plowshare/plowshare-2.1.6.ebuild b/net-misc/plowshare/plowshare-2.1.6-r1.ebuild
index 52227ef820ef..cacd5eb72e61 100644
--- a/net-misc/plowshare/plowshare-2.1.6.ebuild
+++ b/net-misc/plowshare/plowshare-2.1.6-r1.ebuild
@@ -1,19 +1,16 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-inherit bash-completion-r1
+EAPI=7
DESCRIPTION="Command-line downloader and uploader for file-sharing websites"
HOMEPAGE="https://github.com/mcrapet/plowshare"
+SRC_URI="https://github.com/mcrapet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="bash-completion +javascript view-captcha"
-
-SRC_URI="https://github.com/mcrapet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="+javascript view-captcha"
RDEPEND="
>=app-shells/bash-4
@@ -24,7 +21,6 @@ RDEPEND="
virtual/imagemagick-tools[tiff]
javascript? ( || ( dev-lang/spidermonkey:0 dev-java/rhino ) )
view-captcha? ( || ( media-gfx/aview media-libs/libcaca ) )"
-DEPEND=""
# NOTES:
# javascript dep should be any javascript interpreter using /usr/bin/js
@@ -33,12 +29,6 @@ src_prepare() {
# Fix doc install path
sed -i -e "/^DOCDIR/s|plowshare|${PF}|" Makefile || die "sed failed"
- if ! use bash-completion
- then
- sed -i -e \ "/^install:/s/install_bash_completion//" \
- Makefile || die "sed failed"
- fi
-
default
}
diff --git a/net-misc/plowshare/plowshare-2.1.7.ebuild b/net-misc/plowshare/plowshare-2.1.7-r1.ebuild
index 52227ef820ef..cacd5eb72e61 100644
--- a/net-misc/plowshare/plowshare-2.1.7.ebuild
+++ b/net-misc/plowshare/plowshare-2.1.7-r1.ebuild
@@ -1,19 +1,16 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-inherit bash-completion-r1
+EAPI=7
DESCRIPTION="Command-line downloader and uploader for file-sharing websites"
HOMEPAGE="https://github.com/mcrapet/plowshare"
+SRC_URI="https://github.com/mcrapet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="bash-completion +javascript view-captcha"
-
-SRC_URI="https://github.com/mcrapet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="+javascript view-captcha"
RDEPEND="
>=app-shells/bash-4
@@ -24,7 +21,6 @@ RDEPEND="
virtual/imagemagick-tools[tiff]
javascript? ( || ( dev-lang/spidermonkey:0 dev-java/rhino ) )
view-captcha? ( || ( media-gfx/aview media-libs/libcaca ) )"
-DEPEND=""
# NOTES:
# javascript dep should be any javascript interpreter using /usr/bin/js
@@ -33,12 +29,6 @@ src_prepare() {
# Fix doc install path
sed -i -e "/^DOCDIR/s|plowshare|${PF}|" Makefile || die "sed failed"
- if ! use bash-completion
- then
- sed -i -e \ "/^install:/s/install_bash_completion//" \
- Makefile || die "sed failed"
- fi
-
default
}
diff --git a/net-misc/plowshare/plowshare-9999.ebuild b/net-misc/plowshare/plowshare-9999.ebuild
index a0c97507680a..1c454b8d9c40 100644
--- a/net-misc/plowshare/plowshare-9999.ebuild
+++ b/net-misc/plowshare/plowshare-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit bash-completion-r1 git-r3
+inherit git-r3
DESCRIPTION="Command-line downloader and uploader for file-sharing websites"
HOMEPAGE="https://github.com/mcrapet/plowshare"
@@ -11,8 +11,7 @@ EGIT_REPO_URI="https://github.com/mcrapet/plowshare.git"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
-IUSE="bash-completion +javascript view-captcha"
+IUSE="+javascript view-captcha"
RDEPEND="
>=app-shells/bash-4
@@ -23,7 +22,6 @@ RDEPEND="
virtual/imagemagick-tools[tiff]
javascript? ( || ( dev-lang/spidermonkey:0 dev-java/rhino ) )
view-captcha? ( || ( media-gfx/aview media-libs/libcaca ) )"
-DEPEND=""
# NOTES:
# javascript dep should be any javascript interpreter using /usr/bin/js
@@ -32,12 +30,6 @@ src_prepare() {
# Fix doc install path
sed -i -e "/^DOCDIR/s|plowshare|${PF}|" Makefile || die "sed failed"
- if ! use bash-completion
- then
- sed -i -e \ "/^install:/s/install_bash_completion//" \
- Makefile || die "sed failed"
- fi
-
default
}