summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-06 11:52:35 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-06 11:52:35 +0300
commitf185929d2e82d44c01a8ef44bc42913fe71db5b9 (patch)
treea00db973995cae52c0e16de5a0f3915ccbe98326
parentapp-crypt/gnupg: Removed old (diff)
downloadgentoo-f185929d2e82d44c01a8ef44bc42913fe71db5b9.tar.gz
gentoo-f185929d2e82d44c01a8ef44bc42913fe71db5b9.tar.bz2
gentoo-f185929d2e82d44c01a8ef44bc42913fe71db5b9.zip
dev-python/mmtf-python: enable py3.10, enable tests, EAPI=8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild b/dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild
index 30c4a5814f61..fd6c4965d1ce 100644
--- a/dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild
+++ b/dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="The python implementation of the MMTF API, decoder and encoder"
@@ -13,9 +13,16 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="dev-python/msgpack[${PYTHON_USEDEP}]"
BDEPEND="
- dev-python/msgpack[${PYTHON_USEDEP}]"
-RDEPEND="
- ${BDEPEND}"
+ test? (
+ ${RDEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" mmtf/tests/codec_tests.py -v || die "Tests failed with ${EPYTHON}"
+}