summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-02-25 10:14:55 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-25 10:14:55 +0100
commitf1a0c0999145e288fa5a3e2fc3ca5f080c547437 (patch)
treea29e4a9606690cc7983426c4ebab60eacfdeb42b
parentx11-misc/numlockx: adopt through proxy-maint (diff)
downloadgentoo-f1a0c0999145e288fa5a3e2fc3ca5f080c547437.tar.gz
gentoo-f1a0c0999145e288fa5a3e2fc3ca5f080c547437.tar.bz2
gentoo-f1a0c0999145e288fa5a3e2fc3ca5f080c547437.zip
x11-misc/numlockx: EAPI-7 bump + respect LDFLAGS
LDFLAGS were used for building but not the -lXext/Xtst configure tests. Also removed HOMEPAGE, upstream doesn't seem to exist anymore. Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--x11-misc/numlockx/numlockx-1.2.ebuild30
1 files changed, 13 insertions, 17 deletions
diff --git a/x11-misc/numlockx/numlockx-1.2.ebuild b/x11-misc/numlockx/numlockx-1.2.ebuild
index bd6dcd1d7a2a..5d4050ff9f5c 100644
--- a/x11-misc/numlockx/numlockx-1.2.ebuild
+++ b/x11-misc/numlockx/numlockx-1.2.ebuild
@@ -1,38 +1,34 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
+
inherit autotools
-DESCRIPTION="Turns on numlock in X"
-HOMEPAGE="https://home.kde.org/~seli/numlockx/"
+DESCRIPTION="Changes keyboard's numlock state under X"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ppc ppc64 sparc x86"
-IUSE=""
RDEPEND="
x11-libs/libX11
x11-libs/libXext
- x11-libs/libXtst
-"
+ x11-libs/libXtst"
DEPEND="
${RDEPEND}
- x11-base/xorg-proto
-"
+ x11-base/xorg-proto"
src_prepare() {
- sed -i \
- -e '/^K_.*$/d' \
- -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
- configure.in || die
- sed -i -e 's,@X_[_A-Z]\+@,,g' Makefile.am || die
+ default
+ mv configure.{in,ac} || die
+ sed -i '/^K_/d; s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac || die
+ sed -i 's/@X_.*@//g' Makefile.am || die
eautoreconf
}
-src_install() {
- dobin ${PN}
- dodoc AUTHORS README
+src_configure() {
+ econf X_LDFLAGS="${LDFLAGS}"
}