summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-08-23 13:00:18 +0100
committerMarek Szuba <marecki@gentoo.org>2023-08-23 22:05:48 +0100
commitf1a95689f5c9e5372b4dcde71f751d95c84d752f (patch)
tree4ab823fdca73b3cabf5d4248d807046a2dee8fb3
parentdev-python/mkdocstrings: fix the PyPI URI in HOMEPAGE (diff)
downloadgentoo-f1a95689.tar.gz
gentoo-f1a95689.tar.bz2
gentoo-f1a95689.zip
dev-python/uritools: new package, add 4.0.1
New second-order dependency of app-admin/ansible-lint. Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/uritools/Manifest1
-rw-r--r--dev-python/uritools/metadata.xml31
-rw-r--r--dev-python/uritools/uritools-4.0.1.ebuild24
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/uritools/Manifest b/dev-python/uritools/Manifest
new file mode 100644
index 000000000000..6fb35aec4386
--- /dev/null
+++ b/dev-python/uritools/Manifest
@@ -0,0 +1 @@
+DIST uritools-4.0.1.tar.gz 23524 BLAKE2B ca1d0e739436211838df50b1fe7949c5a43f9bf17ec24cf4b5f5748bcb4a330d677134e568a1683422c80a1cc178bd1f4325df7f0e27ac3af09a025fd95513ac SHA512 d616103a74161ed3f2920d2c6aa75cbfc7425940c46097a7b3701d3db3b8771f012bce17dd595d56154fe7ac00527a6bc989810c2e0beb4556e5caa5720e085e
diff --git a/dev-python/uritools/metadata.xml b/dev-python/uritools/metadata.xml
new file mode 100644
index 000000000000..b327baf4c3b1
--- /dev/null
+++ b/dev-python/uritools/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ For various reasons, ``urllib.parse`` and its Python 2 predecessor
+ ``urlparse`` are not compliant with current Internet standards. As
+ stated in `Lib/urllib/parse.py
+ &lt;https://github.com/python/cpython/blob/3.8/Lib/urllib/parse.py&gt;`_:
+
+ RFC 3986 is considered the current standard and any future changes
+ to urlparse module should conform with it. The urlparse module is
+ currently not entirely compliant with this RFC due to defacto
+ scenarios for parsing, and for backward compatibility purposes,
+ some parsing quirks from older RFCs are retained.
+
+ This module aims to provide fully RFC 3986 compliant replacements for
+ the most commonly used functions found in ``urllib.parse``. It also
+ includes functions for distinguishing between the different forms of
+ URIs and URI references, and for conveniently creating URIs from their
+ individual components.
+ </longdescription>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">uritools</remote-id>
+ <remote-id type="github">tkem/uritools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/uritools/uritools-4.0.1.ebuild b/dev-python/uritools/uritools-4.0.1.ebuild
new file mode 100644
index 000000000000..3369476d3621
--- /dev/null
+++ b/dev-python/uritools/uritools-4.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+DOCS_BUILDER="sphinx"
+PYTHON_COMPAT=( python3_{10..12} )
+
+DOCS_DIR="docs"
+
+inherit distutils-r1 docs pypi
+
+DESCRIPTION="RFC 3986-compliant URI parsing, classification and composition"
+HOMEPAGE="
+ https://github.com/tkem/uritools/
+ https://pypi.org/project/uritools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+distutils_enable_tests pytest