summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-04 04:27:00 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-04 04:45:23 +0200
commitf1b0a15b1dd445a96ee61e6a7f9e9855104a08d8 (patch)
tree36650e1855395467c23d4cbbd619479179bb79ec
parentx11-themes/adwaita-icon-theme: Version bump to 45_rc (diff)
downloadgentoo-f1b0a15b1dd445a96ee61e6a7f9e9855104a08d8.tar.gz
gentoo-f1b0a15b1dd445a96ee61e6a7f9e9855104a08d8.tar.bz2
gentoo-f1b0a15b1dd445a96ee61e6a7f9e9855104a08d8.zip
dev-python/zeroconf: Bump to 0.97.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.97.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 7c0aba74cde8..4b59062fae6e 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -5,3 +5,4 @@ DIST zeroconf-0.88.0.tar.gz 150009 BLAKE2B 45a8abca7bbda4246af8838818cffda445bae
DIST zeroconf-0.90.0.tar.gz 150318 BLAKE2B 5239571a4b65f736a799b285d11221636a26d6cf19625bd276baa346a61420519698e13bcfa5909a5ece3026aeb2229a143824915d15ee1d01bfc7c9ef956809 SHA512 82c8d9410f0f6fe0f2ab3136034f4d62752eec0b4c3e5acc0689a0aa817fd9aa33555a0b92f18c224a3ac8b90dd583d77bf372637a20b889d0d8be9e4d8e0458
DIST zeroconf-0.91.1.tar.gz 150551 BLAKE2B 220e6b5684d503c7d1c594196ffa7ecc4f06975accad2ad64a6dd0a75881326110bbf897e74a2a176307fc392fc9fce903c77bbf9fc70fec84f193072bd7a016 SHA512 852946a2f823de1dc25dda5321ec23c67e3893fd8dcf55391e001afb01eb4c8143813aaa0950fddbea6634975eb0904a6e3b500cbe082e843da301c0cd704e9a
DIST zeroconf-0.93.1.tar.gz 151476 BLAKE2B 46a866c6d8268c4688b33c1da04a6a31ef3556fb9264df2e85b038ae832cfdc7567139bff01c9324a4087b449b2dd5ba9688eccfaa0892af49f5cab3ad735600 SHA512 ee5f8aac916f05fc6518e76eb4ee40dd0df507cde1a5f25edfb15ded6ac36d2026283d6160ec7b71ee0344648e181e06ebf0559345ac4b2078f5d9cbf1a83eea
+DIST zeroconf-0.97.0.tar.gz 152115 BLAKE2B 53b514ca3e42c75bf449255db0494de66bdbec74495fec45fd26185ec27d255de0745644b03650cec7a0acba3440075c52058b1a862048fa58587ed5d45907fa SHA512 4a67335e42ffd60236d61fce77b36f747ee71038066e65e2d72e7be3ffa6bf075120b657067aadda89a814dc354a7e26a48627df55782869caa9d95e0956d361
diff --git a/dev-python/zeroconf/zeroconf-0.97.0.ebuild b/dev-python/zeroconf/zeroconf-0.97.0.ebuild
new file mode 100644
index 000000000000..b3ff07347a6d
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.97.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export REQUIRE_CYTHON=1
+
+python_test() {
+ local -x SKIP_IPV6=1
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}