summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-07 12:26:55 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-07 12:28:17 +0100
commitf1b2e63e6cefbf8982a84d22b2e417110a45e08a (patch)
tree62c56601475359f9dc7750cbad2a0ca7078d7c23
parentsci-misc/jupyterlab-desktop-bin: drop 3.4.5.1-r1 (diff)
downloadgentoo-f1b2e63e.tar.gz
gentoo-f1b2e63e.tar.bz2
gentoo-f1b2e63e.zip
dev-python/pylint-venv: new package, add 2.3.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/pylint-venv/Manifest1
-rw-r--r--dev-python/pylint-venv/metadata.xml13
-rw-r--r--dev-python/pylint-venv/pylint-venv-2.3.0.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pylint-venv/Manifest b/dev-python/pylint-venv/Manifest
new file mode 100644
index 000000000000..e923065b1a81
--- /dev/null
+++ b/dev-python/pylint-venv/Manifest
@@ -0,0 +1 @@
+DIST pylint-venv-2.3.0.gh.tar.gz 4967 BLAKE2B 7095848b28f1128d44164fecbd1fd1c3694140d8b3818fefcab92aa5a4083608dfc36c96a6c30b117a8592bea0de9b92a537c33f8db4ce8c1285a575d1aa2131 SHA512 c3f9294a137cc6369984cf714196ee0a248471990f2c6e691da86f3048126b99775cc8e9c516c72bd8746d0d814a52387eca165c5f1960aa418ec5abb13a3bed
diff --git a/dev-python/pylint-venv/metadata.xml b/dev-python/pylint-venv/metadata.xml
new file mode 100644
index 000000000000..7aad6578435c
--- /dev/null
+++ b/dev-python/pylint-venv/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pylint-venv</remote-id>
+ <remote-id type="github">jgosmann/pylint-venv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pylint-venv/pylint-venv-2.3.0.ebuild b/dev-python/pylint-venv/pylint-venv-2.3.0.ebuild
new file mode 100644
index 000000000000..b609a2267b22
--- /dev/null
+++ b/dev-python/pylint-venv/pylint-venv-2.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Init-hook to use the same Pylint with different virtual environments"
+HOMEPAGE="
+ https://pypi.org/project/pylint-venv/
+ https://github.com/jgosmann/pylint-venv/
+"
+SRC_URI="
+ https://github.com/jgosmann/pylint-venv/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pylint[${PYTHON_USEDEP}]
+"