summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-06-11 09:11:43 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-06-11 09:17:25 -0400
commitf1ba4857b1bdbcdfafb336309a6675169e6502f2 (patch)
tree08cd1366d3312b6c3758a2ff0eacf299d89ae48a
parentapp-misc/asciinema: Keyword 2.2.0-r1 riscv, #851120 (diff)
downloadgentoo-f1ba4857b1bdbcdfafb336309a6675169e6502f2.tar.gz
gentoo-f1ba4857b1bdbcdfafb336309a6675169e6502f2.tar.bz2
gentoo-f1ba4857b1bdbcdfafb336309a6675169e6502f2.zip
www-client/qutebrowser: disable py3.11
Rare but can randomly crash with 3.11b3 which can be quite annoying, believed to be a cpython beta bug rather than in qutebrowser (see ebuild comment). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--www-client/qutebrowser/qutebrowser-2.5.1.ebuild3
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/www-client/qutebrowser/qutebrowser-2.5.1.ebuild b/www-client/qutebrowser/qutebrowser-2.5.1.ebuild
index 6011faed3b7d..09bc4c14cb21 100644
--- a/www-client/qutebrowser/qutebrowser-2.5.1.ebuild
+++ b/www-client/qutebrowser/qutebrowser-2.5.1.ebuild
@@ -5,7 +5,8 @@ EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+# py3.11: wait for https://github.com/python/cpython/issues/93252
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 optfeature xdg
if [[ ${PV} == 9999 ]]; then
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index 6011faed3b7d..09bc4c14cb21 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -5,7 +5,8 @@ EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+# py3.11: wait for https://github.com/python/cpython/issues/93252
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 optfeature xdg
if [[ ${PV} == 9999 ]]; then