summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-25 07:43:20 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-25 07:58:36 +0200
commitf1c7d0de167f94252153ea9f6ec80dd0cd744949 (patch)
treecb8d1f331d22de15a2562e5748aed37e113c9a81
parentdev-python/pyparsing: Bump to 3.0.1 (diff)
downloadgentoo-f1c7d0de167f94252153ea9f6ec80dd0cd744949.tar.gz
gentoo-f1c7d0de167f94252153ea9f6ec80dd0cd744949.tar.bz2
gentoo-f1c7d0de167f94252153ea9f6ec80dd0cd744949.zip
dev-python/nuitka: Bump to 0.6.17.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-0.6.17.4.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index f55669117cfb..258bc9f2abc6 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1 +1,2 @@
DIST Nuitka-0.6.17.3.tar.gz 3147197 BLAKE2B fa72985494a362e430dd5eda0b14b5ff0620eb2d5a607cbae58802b92d9cf73d810864f00c366508dd89d8e7989bfbbdbd07b4309839ec36df224d45fa264a4c SHA512 dcda36320e1c9de269f0407869b15f47b960fada87fd6fb60b2e96cdd637f6a773042f0ca30e3d25c8e111a5fe86e69242424e982651af732ca840afd010a909
+DIST Nuitka-0.6.17.4.tar.gz 3147951 BLAKE2B b82a28aab93b2ee570820c1e59f15c49649f799d97f17aec9a66e47d60563e30f5028126c3547b69e168ab425991d8e592a6dc8639971a22a44ad83cfb19d32b SHA512 0bee622d516357851cd96fc3df3dd8e550b296d5045548f40a6b02565e95b2b326b6aa6a8ae54c44d16c641ba7113a38966115967c58c6df4ab4a6ed81e9031f
diff --git a/dev-python/nuitka/nuitka-0.6.17.4.ebuild b/dev-python/nuitka/nuitka-0.6.17.4.ebuild
new file mode 100644
index 000000000000..758649696b8e
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.17.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${S}/${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+ doman doc/nuitka.1 doc/nuitka3.1 doc/nuitka3-run.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}