summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-08 23:03:16 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-08 23:18:56 +0100
commitf1e1fca21dafbdda7ec207c51aae469f21c497ef (patch)
tree3cb3e0df6e7cfe02d64a93b704d9f5a8fbce55b9
parentsys-libs/compiler-rt-sanitizers: Control lit job count (diff)
downloadgentoo-f1e1fca21dafbdda7ec207c51aae469f21c497ef.tar.gz
gentoo-f1e1fca21dafbdda7ec207c51aae469f21c497ef.tar.bz2
gentoo-f1e1fca21dafbdda7ec207c51aae469f21c497ef.zip
sys-libs/llvm-libunwind: Control lit job count
Closes: https://bugs.gentoo.org/649554
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild4
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
index 87f9ee1eb39b..789d9a6d71c7 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-6.0.9999.ebuild
@@ -7,7 +7,7 @@ EAPI=6
# (needed due to CMAKE_BUILD_TYPE != Gentoo)
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit cmake-multilib git-r3 llvm python-any-r1
+inherit cmake-multilib git-r3 llvm multiprocessing python-any-r1
DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://github.com/llvm-mirror/libunwind"
@@ -72,7 +72,7 @@ multilib_src_configure() {
if use test; then
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv"
+ -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}"/libcxx
)
fi
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
index 02cd558be9ab..c16358fe4c62 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
@@ -7,7 +7,7 @@ EAPI=6
# (needed due to CMAKE_BUILD_TYPE != Gentoo)
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit cmake-multilib git-r3 llvm python-any-r1
+inherit cmake-multilib git-r3 llvm multiprocessing python-any-r1
DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://github.com/llvm-mirror/libunwind"
@@ -71,7 +71,7 @@ multilib_src_configure() {
if use test; then
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv"
+ -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
-DLIBUNWIND_LIBCXX_PATH="${WORKDIR}"/libcxx
)
fi